PAT-1010 Radix

1010 Radix(25 分)

Given a pair of positive integers, for example, 6 and 110, can this equation 6 = 110 be true? The answer is yes, if 6 is a decimal number and 110 is a binary number.

Now for any pair of positive integers N​1​​ and N​2​​, your task is to find the radix of one number while that of the other is given.

Input Specification:

Each input file contains one test case. Each case occupies a line which contains 4 positive integers:


N1 N2 tag radix

Here N1 and N2 each has no more than 10 digits. A digit is less than its radix and is chosen from the set { 0-9, a-z } where 0-9 represent the decimal numbers 0-9, and a-zrepresent the decimal numbers 10-35. The last number radix is the radix of N1 if tag is 1, or of N2 if tag is 2.

Output Specification:

For each test case, print in one line the radix of the other number so that the equation N1 = N2 is true. If the equation is impossible, print Impossible. If the solution is not unique, output the smallest possible radix.

Sample Input 1:

6 110 1 10

Sample Output 1:

2

Sample Input 2:

1 ab 1 2

Sample Output 2:

Impossible

不用二分查找会有一个测试点过不去。getdec()函数会溢出,所以要特判溢出的情况。

#include<stdio.h>
#include<string>
#include<vector>
#include<algorithm>
using namespace std;
typedef long long ll;
ll toNum(char t){
	if(t>='0'&&t<='9')
		return t-'0';
	if(t>='a'&&t<='z')
		return t-'a'+10;
	return 1;
}
ll getdec(string s,ll r){
	ll a=0;
	for(int i=0;i<s.size();i++){
		a+=toNum(s[i]);
		if(i!=s.size()-1)
			a*=r;
	}
	return a;
}
ll getr(string s,ll dec){
	string tmp=s;
	sort(tmp.begin(),tmp.end());
	ll r=toNum(tmp[tmp.size()-1])+1;
	if(r<2)r=2;
	ll min=r,max=1e10,t;
	ll mid=(min+max)/2;
	while(mid>min){
		t=getdec(s,mid);
		if(t>=dec||t<0){
			max=mid;
		}else{
			min=mid;
		}
		mid=(min+max)/2;
	}
	t=getdec(s,mid);
	if(t!=dec) {
		t=getdec(s,++mid);
		if(t!=dec) {
			return -1;
		}
	}
	return mid;
}
int main(){
	char n1[15],n2[15];ll tag,r;
	scanf("%s%s%lld%lld",n1,n2,&tag,&r);

	ll t=0,ans=-1;
	if(tag==1){
		t=getdec(string(n1),r);
		ans=getr(string(n2),t);
	}else {
		t=getdec(string(n2),r);
		ans=getr(string(n1),t);
	}
	if(ans==-1)
		printf("Impossible\n");
	else
		printf("%lld\n",ans);

	return 0;
}

 

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值