POJ 3070

 
Fibonacci
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 1253 Accepted: 878

Description

In the Fibonacci integer sequence, F0 = 0, F1 = 1, and Fn = Fn − 1 + Fn − 2 for n ≥ 2. For example, the first ten terms of the Fibonacci sequence are:

0, 1, 1, 2, 3, 5, 8, 13, 21, 34, …

An alternative formula for the Fibonacci sequence is

.

Given an integer n, your goal is to compute the last 4 digits of Fn.

Input

The input test file will contain multiple test cases. Each test case consists of a single line containing n (where 0 ≤ n ≤ 1,000,000,000). The end-of-file is denoted by a single line containing the number −1.

Output

For each test case, print the last four digits of Fn. If the last four digits of Fn are all zeros, print ‘0’; otherwise, omit any leading zeros (i.e., print Fn mod 10000).

Sample Input

0
9
999999999
1000000000
-1

Sample Output

0
34
626
6875

Hint

As a reminder, matrix multiplication is associative, and the product of two 2 × 2 matrices is given by

.

Also, note that raising any 2 × 2 matrix to the 0th power gives the identity matrix:

.

Source

------------------------------------------------------------------------------------------------------------------------------------------------
难度:2    代码:  1      分类: 数学
分析:
题目的难点在于n可能很大,所以把所有的都算出来是不现实的,需要使用位运算,利用n=sigma(2^i*t),t={0,1}来计算。
 
#include  < stdio.h >

int  p[ 30 ][ 4 ] = {1,1,1,0} ;

void  mm( int   *  ret, int   *  a, int   *  b)
{
    
int x[4],y[4],i;
    
for(i=0;i<4;i++)
    
{
        x[i]
=a[i];
        y[i]
=b[i];
    }
    
    ret[
0= (x[0]*y[0+ x[1]*y[2]) % 10000;
    ret[
1= (x[0]*y[1+ x[1]*y[3]) % 10000;
    ret[
2= (x[2]*y[0+ x[3]*y[2]) % 10000;
    ret[
3= (x[2]*y[1+ x[3]*y[3]) % 10000;    
}


int  main()
{
    
int i,n;
    
int a[4]={0,1,1,0};
    
for(i=1;i<30;i++)
    
{
        mm(p[i],p[i
-1],p[i-1]);
    }

    
while(1)
    
{
        scanf(
"%d",&n);
        
if(n==-1break;
        a[
0]=1;a[1]=0;a[2]=0;a[3]=1;
        
        
for(i=0;i<30;i++)
        
{
            
if(n&(1<<i))
            
{
                mm(a,a,p[i]);
            }

        }

        printf(
"%d ",a[1]);
    }


}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 1
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值