HDU 2701 Max Factor

传送门:点击打开链接

Max Factor

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 8635    Accepted Submission(s): 2817


Problem Description
To improve the organization of his farm, Farmer John labels each of his N (1 <= N <= 5,000) cows with a distinct serial number in the range 1..20,000. Unfortunately, he is unaware that the cows interpret some serial numbers as better than others. In particular, a cow whose serial number has the highest prime factor enjoys the highest social standing among all the other cows.

(Recall that a prime number is just a number that has no divisors except for 1 and itself. The number 7 is prime while the number 6, being divisible by 2 and 3, is not).

Given a set of N (1 <= N <= 5,000) serial numbers in the range 1..20,000, determine the one that has the largest prime factor.
 

Input
* Line 1: A single integer, N

* Lines 2..N+1: The serial numbers to be tested, one per line
 

Output
* Line 1: The integer with the largest prime factor. If there are more than one, output the one that appears earliest in the input file.
 

Sample Input
  
  
4 36 38 40 42
 

Sample Output
  
  
38

题意就是给你 n 个数,求出这些数中,因数为素数且最大的数。若都是素数,则需要输出最大的数。

素数打表,若i是素数,则a[i]=1。为了防止都是素数,先进行排序。然后倒序查找最大的质因数。


代码实现:


#include<iostream>
#include<cstring>
#include<algorithm>

using namespace std;

int a[50000];
int main()
{
	memset(a,1,sizeof(a));
	a[0]=0;a[1]=0;a[1]=0;a[2]=1;
	
	for(int i=2;i<=20005;i++)
	{
		if(a[i])
		{
			for(int j=i+i;j<=20005;j=j+i)
			{
				a[j]=0;
			}
		}
		
	}
	
	int n,i,j,map[5005],sum,max,flag,k;
	while(cin>>n)
	{
		max=-1;
		for(i=0;i<n;i++)
		cin>>map[i];
		
		sort(map,map+n);
		for(i=0;i<n;i++)
		{
			for(j=map[i];j>=1;j--)
			{
				k=1;
				if(a[j])
				{
					if(map[i]%j==0)
					{
						sum=j;
						k=0;
					}
				}
				if(k==0)
				break;
			}
			if(sum>max)
			{
				max=sum;
				flag=i;
			}
			
		}
		if(max==1)
		cout<<map[n-1]<<endl;
		else
		cout<<map[flag]<<endl;
	}
	return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值