HDU 1024 Max Sum Plus Plus(最大m子段和)

传送门:点击打开链接

Max Sum Plus Plus

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 30715    Accepted Submission(s): 10845


Problem Description
Now I think you have got an AC in Ignatius.L's "Max Sum" problem. To be a brave ACMer, we always challenge ourselves to more difficult problems. Now you are faced with a more difficult problem.

Given a consecutive number sequence S 1, S 2, S 3, S 4 ... S x, ... S n (1 ≤ x ≤ n ≤ 1,000,000, -32768 ≤ S x ≤ 32767). We define a function sum(i, j) = S i + ... + S j (1 ≤ i ≤ j ≤ n).

Now given an integer m (m > 0), your task is to find m pairs of i and j which make sum(i 1, j 1) + sum(i 2, j 2) + sum(i 3, j 3) + ... + sum(i m, j m) maximal (i x ≤ i y ≤ j x or i x ≤ j y ≤ j x is not allowed).

But I`m lazy, I don't want to write a special-judge module, so you don't have to output m pairs of i and j, just output the maximal summation of sum(i x, j x)(1 ≤ x ≤ m) instead. ^_^
 

Input
Each test case will begin with two integers m and n, followed by n integers S 1, S 2, S 3 ... S n.
Process to the end of file.
 

Output
Output the maximal summation described above in one line.
 

Sample Input
  
  
1 3 1 2 3 2 6 -1 4 -2 3 -2 3
 

Sample Output
  
  
6 8
Hint
Huge input, scanf and dynamic programming is recommended.

裸的最大m子段和问题,题目最后提示cin,cout可能会超时,还好889ms,差了好几个15ms。

如果有对最大m子段和不了解的可以戳这里:点击打开链接 点击打开链接

最大m子段和,巧妙地将二维dp优化为一维,避免数组太大开不出来的问题。此题为模板题,具体解释在代码中,准备拿最大环形m子段和是谁手,下篇博客见。


代码实现:


#include<iostream>
#include<algorithm>
#include<cstring>
#include<cmath>
#include<queue>
#include<cstdio>
#define ll long long
#define mset(a,x) memset(a,x,sizeof(a))

using namespace std;
const double PI=acos(-1);
const int inf=0x3f3f3f3f;
const double esp=1e-6;
const int maxn=1e6+5;
const int mod=1e9+7;

int dp[maxn],map[maxn],mmax[maxn];
//dp[i]代表当前选取i个数中,从1到i的和是多少,mmax储存前一行的数值 

int main()
{
	int n,m,i,j,k;
	while(cin>>m>>n)
	{
		for(i=1;i<=n;i++)
		cin>>map[i];
		
		mset(dp,0);
		mset(mmax,0);
		int maxx;
		for(i=1;i<=m;i++)   //枚举m次选择 
		{
			maxx=-inf;      //初始为最小 
			for(j=i;j<=n;j++)   //枚举每一次选择 
			{
				dp[j]=max(dp[j-1]+map[j],mmax[j-1]+map[j]);  //当前值取前j-1个数的和跟前一行的和的最大值 
				mmax[j-1]=maxx;  //储存前一行 
				maxx=max(dp[j],maxx);  //储存最大值 
			}
		}
		cout<<maxx<<endl;
	}
	return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值