NEU 1008 Friends number

传送门:点击打开链接

1008: Friends number

时间限制: 1 Sec   内存限制: 128 MB
提交: 715   解决: 214
[ 提交][ 状态][ 讨论版]

题目描述

Paula and Tai are couple. There are many stories between them. The day Paula left by airplane, Tai send one message to telephone 2200284, then, everything is changing… (The story in “the snow queen”).

After a long time, Tai tells Paula, the number 220 and 284 is a couple of friends number, as they are special, all divisors of 220’s sum is 284, and all divisors of 284’s sum is 220. Can you find out there are how many couples of friends number less than 10,000. Then, how about 100,000, 200,000 and so on.

The task for you is to find out there are how many couples of friends number in given closed interval [a,b]

输入

There are several cases.

Each test case contains two positive integers a, b(1<= a <= b <=500,000).

Proceed to the end of file.

输出

For each test case, output the number of couples in the given range. The output of one test case occupied exactly one line.

样例输入

1 100
1 1000

样例输出

0
1

提示


6 is a number whose sum of all divisors is 6. 6 is not a friend number, these number is called Perfect Number.


来源


水题,1到1000的数中只有一个数,显然5百万的数据数据有很少,预先打好表,发现只有142个数,然后这题就这么过了。


打表代码:

#include<iostream>
#include<algorithm>
#include<cstring>
#include<cmath>
#include<queue>
#include<cstdio>
#define ll long long
#define mset(a,x) memset(a,x,sizeof(a))
#pragma comment(linker,"/STACK:1024000000,1024000000")

using namespace std;
const double PI=acos(-1);
const int inf=0x3f3f3f3f;
const double esp=1e-6;
const int maxn=1e3+5;
const int mod=1e9+7;
int dir[4][2]={0,1,1,0,0,-1,-1,0};
int ans[5000005],visit[5000005];

int main()
{
	int i,j,k;
	mset(ans,0);
	mset(visit,0);
	ans[0]=0;ans[1]=1;
	for(i=2;i<=5000000;i++)
	{
		ans[i]+=1;
		for(j=i+i;j<=5000000;j+=i)
		{
			ans[j]+=i;
		}
	}
	int sum=0;
	for(i=2;i<=5000000;i++)
	{
		if(ans[i]<=5000000&&i!=ans[i]&&i==ans[ans[i]]&&!visit[i])
		{
			int temp=min(i,ans[ans[i]]);
			cout<<temp<<','<<ans[i]<<',';
			visit[i]=1;
			visit[ans[i]]=1;
			sum++;
		}
	}
	cout<<sum<<endl;
}


代码实现:


#include<iostream>
#include<algorithm>
#include<cstring>
#include<cmath>
#include<queue>
#include<cstdio>
#define ll long long
#define mset(a,x) memset(a,x,sizeof(a))
#pragma comment(linker,"/STACK:1024000000,1024000000")

using namespace std;
const double PI=acos(-1);
const int inf=0x3f3f3f3f;
const double esp=1e-6;
const int maxn=1e3+5;
const int mod=1e9+7;
int dir[4][2]={0,1,1,0,0,-1,-1,0};
int ans[200][2]={220,284,1184,1210,2620,2924,5020,5564,6232,6368,10744,10856,12285,14595,17296,18416,63020,76084,66928,66992,67095,71145,69615,87633,79750,88730,100485,124155,122265,139815,122368,123152,141664,153176,142310,168730,171856,176336,176272,180848,185368,203432,196724,202444,280540,365084,308620,389924,319550,430402,356408,399592,437456,455344,469028,486178,503056,514736,522405,525915,600392,669688,609928,686072,624184,691256,635624,712216,643336,652664,667964,783556,726104,796696,802725,863835,879712,901424,898216,980984,947835,1125765,998104,1043096,1077890,1099390,1154450,1189150,1156870,1292570,1175265,1438983,1185376,1286744,1280565,1340235,1328470,1483850,1358595,1486845,1392368,1464592,1466150,1747930,1468324,1749212,1511930,1598470,1669910,2062570,1798875,1870245,2082464,2090656,2236570,2429030,2652728,2941672,2723792,2874064,2728726,3077354,2739704,2928136,2802416,2947216,2803580,3716164,3276856,3721544,3606850,3892670,3786904,4300136,3805264,4006736,4238984,4314616,4246130,4488910,4259750,4445050};

int main()
{
	int n,i,j,k,l,r;
	while(scanf("%d%d",&l,&r)!=EOF)
	{
		int sum=0;
		for(i=0;ans[i][0]!=0;i++)
		if(ans[i][0]>=l&&ans[i][1]<=r)
		sum++;
		
		cout<<sum<<endl;
	}
	return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值