hdu 1702 栈和队列

ACboy needs your help again!

Time Limit: 1000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 2799    Accepted Submission(s): 1462


Problem Description
ACboy was kidnapped!!
he miss his mother very much and is very scare now.You can't image how dark the room he was put into is, so poor :(.
As a smart ACMer, you want to get ACboy out of the monster's labyrinth.But when you arrive at the gate of the maze, the monste say :" I have heard that you are very clever, but if can't solve my problems, you will die with ACboy."
The problems of the monster is shown on the wall:
Each problem's first line is a integer N(the number of commands), and a word "FIFO" or "FILO".(you are very happy because you know "FIFO" stands for "First In First Out", and "FILO" means "First In Last Out").
and the following N lines, each line is "IN M" or "OUT", (M represent a integer).
and the answer of a problem is a passowrd of a door, so if you want to rescue ACboy, answer the problem carefully!

Input
The input contains multiple test cases.
The first line has one integer,represent the number oftest cases.
And the input of each subproblem are described above.

Output
For each command "OUT", you should output a integer depend on the word is "FIFO" or "FILO", or a word "None" if you don't have any integer.

Sample Input
  
  
4 4 FIFO IN 1 IN 2 OUT OUT 4 FILO IN 1 IN 2 OUT OUT 5 FIFO IN 1 IN 2 OUT OUT OUT 5 FILO IN 1 IN 2 OUT IN 3 OUT

Sample Output
  
  
1 2 2 1 1 2 None 2 3

都是基本操作

考察了栈和队列的联系与区别。栈是先进后出,而队列是先进先出。队列可以想象成在超市排队买东西,先排队的人先买到东西。栈就想象成桶堆积物品。STL队列 STL栈

注意:

compare()函数以多种方式比较本字符串和str,返回:
返回值情况
小于零   this < str  
零   this == str  
大于零   this > str

代码如下:

 

#include <iostream>
#include <string>
#include <stack>
#include <queue>
using namespace std;

void queueExe(int n)
{
    int x;
    string s;
    queue<int> q;
    while(n--)
    {
        cin>>s;
        if(s.compare("IN")==0)//if s=='IN'
        {
            cin>>x;
            q.push(x);
        }
        else if(s.compare("OUT")==0)
        {
            if(q.empty())
            {
                cout<<"None"<<endl;
            }
            else
            {
                cout<<q.front()<<endl;//front 队头
                q.pop();
            }
        }
    }
}
void stackExe(int n)
{
    int x;
    string s;
    stack<int> q;
    while(n--)
    {
        cin>>s;
        if(s.compare("IN")==0)
        {
            cin>>x;
            q.push(x);
        }
        else if(s.compare("OUT")==0)
        {
            if(q.empty())
            {
                cout<<"None"<<endl;
            }
            else
            {
                cout<<q.top()<<endl;
                q.pop();
            }
        }
    }
}

int main()
{
    int T,N;
    string strtype;
    string cmd;

    while(cin>>T)
    {
        while(T--)
        {
            cin>>N>>strtype;
            if(strtype.compare("FIFO")==0)
            queueExe(N);

            else if(strtype.compare("FILO")==0)
            stackExe(N);
            else
            cout<<"error"<<endl;
        }
    }
    return 0;
}


 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值