HDU 1160 FatMouse's Speed--经典DP

FatMouse's Speed

Time Limit: 2000/1000 MS (Java/Others)Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 4910 Accepted Submission(s): 2130
Special Judge


Problem Description
FatMouse believes that the fatter a mouse is, the faster it runs. To disprove this, you want to take the data on a collection of mice and put as large a subset of this data as possible into a sequence so that the weights are increasing, but the speeds are decreasing.

Input
Input contains data for a bunch of mice, one mouse per line, terminated by end of file.

The data for a particular mouse will consist of a pair of integers: the first representing its size in grams and the second representing its speed in centimeters per second. Both integers are between 1 and 10000. The data in each test case will contain information for at most 1000 mice.

Two mice may have the same weight, the same speed, or even the same weight and speed.

Output
Your program should output a sequence of lines of data; the first line should contain a number n; the remaining n lines should each contain a single positive integer (each one representing a mouse). If these n integers are m[1], m[2],..., m[n] then it must be the case that

W[m[1]] < W[m[2]] < ... < W[m[n]]

and

S[m[1]] > S[m[2]] > ... > S[m[n]]

In order for the answer to be correct, n should be as large as possible.
All inequalities are strict: weights must be strictly increasing, and speeds must be strictly decreasing. There may be many correct outputs for a given input, your program only needs to find one.

Sample Input
 
6008 1300 6000 2100 500 2000 1000 4000 1100 3000 6000 2000 8000 1400 6000 1200 2000 1900

Sample Output
 
4 4 5 9 7


最长有序子序列的问题
从后向前DP。
设g[I].W表示第i只老鼠的重量,g[i].S表示第i只老鼠的速度。我们先对Mas进行排序,以W为第一关键字,从小到大,S为第二关键字,从大到小。
设f[i]为g[i]至g[n]最长的序列长度。考虑某一个f[i],则有:
f[i] = max(f[i], f[j]+1) (1<=j<i,且g[i].W> g[j].W,g[i].S < g[j].S)

#include<string.h>
#include<stdio.h>
#include<iostream>
#include<algorithm>
using namespace std;


struct mas
{
    int weigt;
    int sped;
    int key;
};


bool cmp(mas x,mas y)
{
    if(x.weigt!=y.weigt)
        return x.weigt<y.weigt;
    else
        return x.sped>y.sped;
}
mas g[1100];
int f[1100];
int main()
{
    int x,y;
    int i=1;
    while(scanf("%d%d",&x,&y)!=EOF)
    {
        g[i].weigt=x;
        g[i].sped=y;
        g[i].key=i;
        i++;
    }
    memset(f,0,sizeof(f));
    sort(g+1,g+i,cmp);
    f[i-1]=1;
    for(int j=i-2; j>=0; j--)
    {
        int max=0;
        for(int k=j+1; k<i; k++)
        {
            if(g[k].sped<g[j].sped&&g[k].weigt>g[j].weigt&&max<f[k])
            {
                max=f[k];
            }
        }
        f[j]=max+1;
    }
    int max1=0;
    int pi;
    for(int j=1; j<i; j++)
    {
        if(f[j]>max1)
        {
            pi=j;
            max1=f[j];
        }
    }
    printf("%d\n",max1);
    for(int j=pi; j<i; j++)
    {
        if(f[j]==max1)
        {
            printf("%d\n",g[j].key);
            max1--;
        }
        if(max1==0)
            break;
    }
    return 0;

}





  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值