大数hdu1002 A+B

A + B Problem II

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 186305    Accepted Submission(s): 35531


Problem Description
I have a very simple problem for you. Given two integers A and B, your job is to calculate the Sum of A + B.


Input
The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line consists of two positive integers, A and B. Notice that the integers are very large, that means you should not process them by using 32-bit integer. You may assume the length of each integer will not exceed 1000.


Output
For each test case, you should output two lines. The first line is "Case #:", # means the number of the test case. The second line is the an equation "A + B = Sum", Sum means the result of A + B. Note there are some spaces int the equation. Output a blank line between two test cases.


Sample Input
  
  
2 1 2 112233445566778899 998877665544332211


Sample Output
  
  
Case 1: 1 + 2 = 3 Case 2: 112233445566778899 + 998877665544332211 = 1111111111111111110
 
 
大数加法运算,加法是尾对齐的,用整型数组sum来存储结果,输入的整数以字符串形式存储。把每位数字对齐相加,此处注意s[i]是字符,要用s[i]-'0'转换成数字。注意进位的算法。
代码如下:
 
#include <iostream>
#include <cstring>
#define SIZE 1001
using namespace std;
int main()
{
    int T,k,i,j,l,m;
    int ls1,ls2;
    char s1[SIZE];
    char s2[SIZE];
    int sum[SIZE]={0};
    cin>>T;
    for(i=0;i<T;i++)
    {
        cin>>s1>>s2;
        ls1=strlen(s1);
        ls2=strlen(s2);
        for(j=ls1-1,k=0;j>=0;j--)
        {
            sum[k++]=s1[j]-'0';
        }
        for(j=ls2-1,k=0;j>=0;j--)
        {
            sum[k++]+=s2[j]-'0';
        }
       if(ls1>ls2)
       l=ls1;
       else
       l=ls2;
        for(j=0;j<l;j++)
        {
            if(sum[j]>=10)
            {
                m=sum[j]/10;
                sum[j]-=m*10;
                sum[j+1]+=m;
            }
            if(sum[l-1]>=10)
            l++;
        }
            cout<<"Case "<<i+1<<":"<<endl;
            cout<<s1<<" + "<<s2<<" = ";
            for(j=l-1;j>=1;j--)
            {
                cout<<sum[j];
                sum[j]=0;
            }
            cout<<sum[0]<<endl;
            if(i<T-1)
           cout<<endl;
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值