Rescue

Rescue

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 13329    Accepted Submission(s): 4858


Problem Description
Angel was caught by the MOLIGPY! He was put in prison by Moligpy. The prison is described as a N * M (N, M <= 200) matrix. There are WALLs, ROADs, and GUARDs in the prison.

Angel's friends want to save Angel. Their task is: approach Angel. We assume that "approach Angel" is to get to the position where Angel stays. When there's a guard in the grid, we must kill him (or her?) to move into the grid. We assume that we moving up, down, right, left takes us 1 unit time, and killing a guard takes 1 unit time, too. And we are strong enough to kill all the guards.

You have to calculate the minimal time to approach Angel. (We can move only UP, DOWN, LEFT and RIGHT, to the neighbor grid within bound, of course.)
 

Input
First line contains two integers stand for N and M.

Then N lines follows, every line has M characters. "." stands for road, "a" stands for Angel, and "r" stands for each of Angel's friend. 

Process to the end of the file.
 

Output
For each test case, your program should output a single integer, standing for the minimal time needed. If such a number does no exist, you should output a line containing "Poor ANGEL has to stay in the prison all his life." 
 

Sample Input
  
  
7 8 #.#####. #.a#..r. #..#x... ..#..#.# #...##.. .#...... ........
 

Sample Output
  
  
13
 

Author
CHEN, Xue
 

Source
 

Recommend
Eddy   |   We have carefully selected several similar problems for you:   1240  1241  1175  1238  1401 



include<stdio.h>
#include<queue>
#include<iostream>
#include<string.h>
using namespace std;
char map[200][200];
int dir[4][2]= {{0,1},{1,0},{0,-1},{-1,0}};
int vis[200][200];
int n,m,sx,sy,ans;
struct node
{
    int x,y,step;
     bool operator<(const node t)const
    {
        return t.step<step;
    }
};
bool judge(int x,int y)
{
    if(x>=1&&x<=n&&y>=1&&y<=m&&map[x][y]!='#'&&!vis[x][y])
        return true;
    return false;
}
node qq;
void BFS(int x,int y)
{
    priority_queue<node>q;
    node next;
    qq.x=x;
    qq.y=y;
    qq.step=0;
    q.push(qq);
    vis[qq.x][qq.y]=1;
    while(!q.empty())
    {
        node first;
        first=q.top();
        q.pop();
        for(int i=0; i<4; i++)
        {
            int xx,yy;
            xx=first.x+dir[i][0];
            yy=first.y+dir[i][1];

            if(xx>=0&&xx<n&&yy>=0&&yy<m&&map[xx][yy]!='#'&&!vis[xx][yy])
            {
                vis[xx][yy]=1;
                if(map[xx][yy]=='r')
                {
                    ans=first.step+1;
                    return;
                }
                next.x=xx;
                next.y=yy;
                if(map[next.x][next.y]=='x')
                {
                    next.step=first.step+2;
                }
                else
                next.step=first.step+1;
                q.push(next);
            }
        }
    }
}
int main()
{
    while(cin>>n>>m)
    {

        for(int i=0; i<n; i++)
        {

            for(int j=0; j<m; j++)
            {
                cin>>map[i][j];
                if(map[i][j]=='a')
                {
                    sx=i;
                    sy=j;
                }
            }
            //getchar();
        }
        ans=-1;
        memset(vis,0,sizeof(vis));
        BFS(sx,sy);
        if(ans!=-1)
            printf("%d\n",ans);
        else
            printf("Poor ANGEL has to stay in the prison all his life.\n");
    }
    return 0;
}


 
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值