又一版 A+B

又一版 A+B

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 12246    Accepted Submission(s): 4629


Problem Description
输入两个不超过整型定义的非负10进制整数A和B(<=2 31-1),输出A+B的m (1 < m <10)进制数。



 

Input
输入格式:测试输入包含若干测试用例。每个测试用例占一行,给出m和A,B的值。
当m为0时输入结束。
 

Output
输出格式:每个测试用例的输出占一行,输出A+B的m进制数。
 

Sample Input
  
  
8 1300 48 2 1 7 0
 

Sample Output
  
  
2504 1000
 

Author
ZJU
 

Source
 

Recommend
We have carefully selected several similar problems for you:   1880  1229  1881  1230  1860 




#include<stdio.h>
#include<algorithm>
#include<cstring>
#include<stack>
#include<cstdio>
#include<iostream>
using namespace std;
 stack<int> p;

int m;
void hanshu(int sum)
{

   if(sum==0)
   printf("0");
   else
   {
       while(sum>0)
       {
           p.push(sum%m);
           sum=sum/m;
       }
   }


}
int main()
{
    int i,j,a,b;
    int sum;

    while(scanf("%d",&m)!=EOF)
    {
        if(m<=0)
        break;
        scanf("%d%d",&a,&b);
        sum=a+b;
        hanshu(sum);
        while(!p.empty())
        {
            //printf("%d",p.top());
            cout<<p.top();
            p.pop();
        }
        printf("\n");
    }







    return 0;
}


 
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值