NBUT1219 Time

  • [1219] Time

  • 时间限制: 1000 ms 内存限制: 131072 K
  • 问题描述
  • Digital clock use 4 digits to express time, each digit is described by 3*3 characters (including”|”,”_”and” “).now given the current time, please tell us how can it be expressed by the digital clock.
  • 输入
  • There are several test cases.
    Each case contains 4 integers in a line, separated by space.
    Proceed to the end of file.
  • 输出
  • For each test case, output the time expressed by the digital clock such as Sample Output.
  • 样例输入
  • 1 2 5 6
    2 3 4 2
  • 样例输出
  •     _  _  _ 
      | _||_ |_ 
      ||_  _||_|
     _  _     _ 
     _| _||_| _|
    |_  _|  ||_ 
  • 提示
  • The digits showed by the digital clock are as follows:
       _  _     _  _  _  _  _  _ 
     | _| _||_||_ |_   ||_||_|| |
     ||_  _|  | _||_|  ||_| _||_|
  • 来源:辽宁省赛2010
    数字分上中下三个部分,找出规律,把相同情况的放在一起
     代码:
 
#include <iostream>
#include <cstring>
using namespace std;
int main()
{
    int a,b,c,d;
    while(cin>>a>>b>>c>>d)
    {
        for(int i=0;i<3;i++)
        {
         for(i=0;i<3;i++)
         {
             if(i==0)
             {
                 if(a==1||a==4)
                 cout<<"   ";
                 else
                 cout<<" _ ";
                 if(b==1||b==4)
                 cout<<"   ";
                 else
                 cout<<" _ ";
                 if(c==1||c==4)
                 cout<<"   ";
                 else
                 cout<<" _ ";
                 if(d==1||d==4)
                 cout<<"   ";
                 else
                 cout<<" _ ";
             }
             if(i==1)
             {
                 if(a==1)
                 cout<<"  |";
                 if(a==2||a==3)
                 cout<<" _|";
                  if(a==5||a==6)
                 cout<<"|_ ";
                  if(a==7)
                 cout<<"  |";
                 if(a==4||a==8||a==9)
                 cout<<"|_|";
                  if(a==0)
                 cout<<"| |";
                 if(b==1)
                 cout<<"  |";
                 if(b==2||b==3)
                 cout<<" _|";
                  if(b==5||b==6)
                 cout<<"|_ ";
                  if(b==7)
                 cout<<"  |";
                 if(b==4||b==8||b==9)
                 cout<<"|_|";
                  if(b==0)
                 cout<<"| |";
                 if(c==1)
                 cout<<"  |";
                 if(c==2||c==3)
                 cout<<" _|";
                  if(c==5||c==6)
                 cout<<"|_ ";
                  if(c==7)
                 cout<<"  |";
                 if(c==4||c==8||c==9)
                 cout<<"|_|";
                  if(c==0)
                 cout<<"| |";
                 if(d==1)
                 cout<<"  |";
                 if(d==2||d==3)
                 cout<<" _|";
                  if(d==5||d==6)
                 cout<<"|_ ";
                  if(d==7)
                 cout<<"  |";
                 if(d==4||d==8||d==9)
                 cout<<"|_|";
                  if(d==0)
                 cout<<"| |";
             }
             if(i==2)
             {
                 if(a==1)
                 cout<<"  |";
                 if(a==2)
                 cout<<"|_ ";
                 if(a==4||a==7)
                 cout<<"  |";
                 if(a==3||a==5||a==9)
                 cout<<" _|";
                 if(a==6||a==8||a==0)
                 cout<<"|_|";
                 if(b==1)
                 cout<<"  |";
                 if(b==2)
                 cout<<"|_ ";
                 if(b==4||b==7)
                 cout<<"  |";
                 if(b==3||b==5||b==9)
                 cout<<" _|";
                 if(b==6||b==8||b==0)
                 cout<<"|_|";
                 if(c==1)
                 cout<<"  |";
                 if(c==2)
                 cout<<"|_ ";
                 if(c==4||c==7)
                 cout<<"  |";
                 if(c==3||c==5||c==9)
                 cout<<" _|";
                 if(c==6||c==8||c==0)
                 cout<<"|_|";
                 if(d==1)
                 cout<<"  |";
                 if(d==2)
                 cout<<"|_ ";
                 if(d==4||d==7)
                 cout<<"  |";
                 if(d==3||d==5||d==9)
                 cout<<" _|";
                 if(d==6||d==8||d==0)
                 cout<<"|_|";
             }
             cout<<endl;
        }
    }
    }
    return 0;
}

   
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值