B - Monkey King

Once in a forest, there lived N aggressive monkeys. At the beginning, they each does things in its own way and none of them knows each other. But monkeys can’t avoid quarrelling, and it only happens between two monkeys who does not know each other. And when it happens, both the two monkeys will invite the strongest friend of them, and duel. Of course, after the duel, the two monkeys and all of there friends knows each other, and the quarrel above will no longer happens between these monkeys even if they have ever conflicted.

Assume that every money has a strongness value, which will be reduced to only half of the original after a duel(that is, 10 will be reduced to 5 and 5 will be reduced to 2).

And we also assume that every monkey knows himself. That is, when he is the strongest one in all of his friends, he himself will go to duel.
Input
There are several test cases, and each case consists of two parts.

First part: The first line contains an integer N(N<=100,000), which indicates the number of monkeys. And then N lines follows. There is one number on each line, indicating the strongness value of ith monkey(<=32768).

Second part: The first line contains an integer M(M<=100,000), which indicates there are M conflicts happened. And then M lines follows, each line of which contains two integers x and y, indicating that there is a conflict between the Xth monkey and Yth.

Output
For each of the conflict, output -1 if the two monkeys know each other, otherwise output the strongness value of the strongest monkey in all friends of them after the duel.
Sample Input
5
20
16
10
10
4
5
2 3
3 4
3 5
4 5
1 5
Sample Output
8
5
5
-1
10

一开始n只猴子都互相不认识,当两只猴子发生冲突时,两边认识的力量最大的猴子开始打架,打架后参与打架的猴子力量减半,并且两群猴子互相都认识了,询问每次冲突后两群猴子中力量最大的猴子。
题解很好理解,每次先把两群猴子中力量最大的拿出来,减半之后放回去,再将两个堆合并,取最大值,当一个结点只有一个子节点时,由于dis都是0!(虽然是左偏树但不一定子节点就是左儿子)所以要取两个儿子中存在的那个。

#include<bits/stdc++.h>
using namespace std;
const int N=1e5+5; 
struct node  //定义结点 
{
    int val, lc, rc, dis, par;
} t[N];
void init(int x)   //结点初始化 
{
    for (int i = 1; i <= x; i++) 
	{
		scanf("%d",&t[i].val);
        t[i].lc = t[i].rc = t[i].dis = 0;
        t[i].par = i;
    }
}

int find(int x) 
{
    if (t[x].par == x) return x;
    else return t[x].par = find(t[x].par);
}
bool same(int x, int y) 
{
    return find(x) == find(y);
}

int merge(int x, int y) {
    if (x == 0)
        return y;
    if (y == 0)
        return x;
    if (t[x].val < t[y].val)
        swap(x, y);
    t[x].rc = merge(t[x].rc, y);
    t[t[x].rc].par = x;
    if (t[t[x].lc].dis < t[t[x].rc].dis)
        swap(t[x].lc, t[x].rc);
    if (t[x].rc == 0)
        t[x].dis = 0;
    else
        t[x].dis = t[t[x].rc].dis + 1;
    return x;
}
int pop(int x) 
{
    int l = t[x].lc, r = t[x].rc;
    t[x].lc = t[x].rc = t[x].dis = 0;
    t[l].par = l, t[r].par = r,t[x].par=x;
    return merge(l, r);
}
int n,m,a,b;
int main()
{
	while(~scanf("%d",&n))
	{
		init(n);
		scanf("%d",&m);
		while(m--)
		{		
			scanf("%d%d",&a,&b);
			if(find(a)==find(b))
			{
				printf("-1\n");
				continue;
			}
			
			int tmp=find(a);
			int lc=max(t[tmp].lc,t[tmp].rc);
			pop(tmp);
			t[tmp].val/=2;
			merge(tmp,find(lc));
			
			tmp=find(b);
			lc=max(t[tmp].lc,t[tmp].rc);		
			pop(tmp);
			t[tmp].val/=2;
			merge(tmp,find(lc));
			
			int ans=merge(find(a),find(b));
			
			printf("%d\n",t[ans].val);
		}
	}
} 
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值