题目:Counting Black

Counting Black

Time Limit : 2000/1000ms (Java/Other)   Memory Limit : 20000/10000K (Java/Other)
Total Submission(s) : 7   Accepted Submission(s) : 5
Problem Description
There is a board with 100 * 100 grids as shown below. The left-top gird is denoted as (1, 1) and the right-bottom grid is (100, 100). 

We may apply three commands to the board: 
1.	WHITE  x, y, L     // Paint a white square on the board, 

                           // the square is defined by left-top grid (x, y)

                           // and right-bottom grid (x+L-1, y+L-1)



2.	BLACK  x, y, L     // Paint a black square on the board, 

                           // the square is defined by left-top grid (x, y)

                           // and right-bottom grid (x+L-1, y+L-1)



3.	TEST     x, y, L    // Ask for the number of black grids 

                            // in the square (x, y)- (x+L-1, y+L-1) 

In the beginning, all the grids on the board are white. We apply a series of commands to the board. Your task is to write a program to give the numbers of black grids within a required region when a TEST command is applied. 
 

Input
The first line of the input is an integer t (1 <= t <= 100), representing the number of commands. In each of the following lines, there is a command. Assume all the commands are legal which means that they won't try to paint/test the grids outside the board.
 

Output
For each TEST command, print a line with the number of black grids in the required region.
 

Sample Input
  
  
5 BLACK 1 1 2 BLACK 2 2 2 TEST 1 1 3 WHITE 2 1 1 TEST 1 1 3
 

Sample Output
  
  
7 6
 

Source
PKU
 

代码:
#include<stdio.h>
#include<string.h>
int main()
{   int x,y,l;
int a[100][100],sum,i,j;
    char str[7];
    for(i=0;i<100;i++)
{    for(j=0;j<100;j++)
{ a[i][j]=0; }
}
    int N;sum=0;
scanf("%d",&N);
while(N--)
{  scanf("%s%d%d%d",&str,&x,&y,&l);
   if(strcmp("TEST",str)==0)
{   sum=0;
for(i=x-1;i<=x+l-2;i++)
{ for(j=y-1;j<=y+l-2;j++)
      if(a[i][j]==1) sum++;
}
  printf("%d\n",sum);
  
}
   else if(strcmp("BLACK",str)==0)
{  
     for(i=x-1;i<=x+l-2;i++)
 {  for(j=y-1;j<=y+l-2;j++)
        a[i][j]=1 ;
 }
}
else if(strcmp(str,"WHITE")==0)
{    
   for(i=x-1;i<=x+l-2;i++)
{ for(j=y-1;j<=y+l-2;j++)
       a[i][j]=0 ;
}
}
   
}
   
return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值