Saving James Bond - Easy Version(Java实现)

14 篇文章 0 订阅

This time let us consider the situation in the movie “Live and Let Die” in which James Bond, the world’s most famous spy, was captured by a group of drug dealers. He was sent to a small piece of land at the center of a lake filled with crocodiles. There he performed the most daring action to escape – he jumped onto the head of the nearest crocodile! Before the animal realized what was happening, James jumped again onto the next big head… Finally he reached the bank before the last crocodile could bite him (actually the stunt man was caught by the big mouth and barely escaped with his extra thick boot).

Assume that the lake is a 100 by 100 square one. Assume that the center of the lake is at (0,0) and the northeast corner at (50,50). The central island is a disk centered at (0,0) with the diameter of 15. A number of crocodiles are in the lake at various positions. Given the coordinates of each crocodile and the distance that James could jump, you must tell him whether or not he can escape.

Input Specification:
Each input file contains one test case. Each case starts with a line containing two positive integers N (≤100), the number of crocodiles, and D, the maximum distance that James could jump. Then N lines follow, each containing the (x,y) location of a crocodile. Note that no two crocodiles are staying at the same position.

Output Specification:
For each test case, print in a line “Yes” if James can escape, or “No” if not.

Sample Input 1:
14 20
25 -15
-25 28
8 49
29 15
-35 -2
5 28
27 -29
-8 -28
-20 -35
-25 -20
-13 29
-30 15
-35 40
12 12
Sample Output 1:
Yes
Sample Input 2:
4 13
-12 12
12 12
-12 -12
12 -12
Sample Output 2:
No

思路:
找出以(0,0)为起点的所有能跳到的联通集,后再进行深度优先搜索看是否有联通路径;

代码如下:

import java.util.ArrayList;
import java.util.List;
import java.util.Scanner;

public class Main {

    //鳄鱼数量
    private Integer croNum;
    //跳的最远距离
    private Integer maxDis;

    public static void main(String[] args){
        Main self = new Main();
        Scanner input = new Scanner(System.in);
        List<Dis> croList = self.handleInput(input);
        boolean flag = self.save007(croList);
        if (flag){
            System.out.println("Yes");
        }else {
            System.out.println("No");
        }
    }

    public List<Dis> handleInput(Scanner input){
        this.croNum = input.nextInt();
        this.maxDis = input.nextInt();
        List<Dis> croList = new ArrayList<>();
        for (int i = 0; i < this.croNum; i++) {
            Dis dis = new Dis(input.nextInt(), input.nextInt());
            croList.add(dis);
        }
        return croList;
    }

    // 查找所有第一跳能跳过去的路线集
    public boolean save007(List<Dis> croList){
        Dis dis = new Dis(0,0);
        for (Dis temp: croList) {
            if (!temp.visited && dis.canJump(temp,this.maxDis)){
                boolean res = DFS(temp, croList);
                if (res){
                    return true;
                }
            }
        }
        return false;
    }

    //深度优先查找
    public boolean DFS(Dis dis, List<Dis> croList){
        dis.visited = true;
        if (dis.isSafe(this.maxDis)){
            return true;
        }
        for (Dis temp: croList) {
            if (!temp.visited && dis.canJump(temp,this.maxDis)){
                boolean res = DFS(temp, croList);
                if (res){
                    return true;
                }
            }
        }
        return false;
    }
}

class Dis{
    private int x;
    private int y;
    boolean visited;

    public Dis(int x, int y) {
        this.x = x;
        this.y = y;
        this.visited = false;
    }

    public boolean canJump(Dis dis, int maxDis){
        double temp = Math.pow(this.x - dis.getX(), 2) + Math.pow(this.y - dis.getY(), 2);
        if(this.x == 0 && this.y == 0){
            return Math.sqrt(temp) <= maxDis + 15;
        }
        return Math.sqrt(temp) <= maxDis;
    }

	//如果是测试点3不正确,考虑是否判断的是>=50;
    public boolean isSafe(int maxDis){
        if (Math.abs(this.x) + maxDis >= 50){
            return true;
        }
        if (Math.abs(this.y) + maxDis >= 50){
            return true;
        }
        return false;
    }

    public int getX() {
        return x;
    }

    public void setX(int x) {
        this.x = x;
    }

    public int getY() {
        return y;
    }

    public void setY(int y) {
        this.y = y;
    }
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值