1099 Build A Binary Search Tree (30 分)

A Binary Search Tree (BST) is recursively defined as a binary tree which has the following properties:

  • The left subtree of a node contains only nodes with keys less than the node's key.
  • The right subtree of a node contains only nodes with keys greater than or equal to the node's key.
  • Both the left and right subtrees must also be binary search trees.

Given the structure of a binary tree and a sequence of distinct integer keys, there is only one way to fill these keys into the tree so that the resulting tree satisfies the definition of a BST. You are supposed to output the level order traversal sequence of that tree. The sample is illustrated by Figure 1 and 2.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (≤100) which is the total number of nodes in the tree. The next N lines each contains the left and the right children of a node in the format left_index right_index, provided that the nodes are numbered from 0 to N−1, and 0 is always the root. If one child is missing, then −1 will represent the NULL child pointer. Finally N distinct integer keys are given in the last line.

Output Specification:

For each test case, print in one line the level order traversal sequence of that tree. All the numbers must be separated by a space, with no extra space at the end of the line.

Sample Input:

9
1 6
2 3
-1 -1
-1 4
5 -1
-1 -1
7 -1
-1 8
-1 -1
73 45 11 58 82 25 67 38 42

Sample Output:

58 25 82 11 38 67 45 73 42

代码: 

 

#include<iostream>
#include<queue>
#include<algorithm>
using namespace std;
int N,index=0,count1=0;
int num[110];
struct node//定义结点
{
    int data;//存放数据
    int lchild;//存放左孩子结点下标
    int rchild;//存放右孩子结点下标
}Node[110];
void inorder(int root)
{
    if(root==-1)//空结点
        return ;
    inorder(Node[root].lchild);//遍历左子树
    Node[root].data=num[index++];//设置结点数据域的值
    inorder(Node[root].rchild);//遍历右子树
}
void levelorder(int root)
{
    queue<int> Q;
    Q.push(root);
    while(!Q.empty())
    {
        int temp=Q.front();
        Q.pop();
        count1++;
        if(count1==1)
            printf("%d",Node[temp].data);
        else
            printf(" %d",Node[temp].data);
        if(Node[temp].lchild!=-1)//左孩子不为空,则左孩子入队
            Q.push(Node[temp].lchild);
        if(Node[temp].rchild!=-1)//右孩子不为空,右孩子入队
            Q.push(Node[temp].rchild);
    }
}
int main()
{
    scanf("%d",&N);
    for(int i=0;i<N;i++)//建树的过程,依次接收每个结点的左右孩子下标
        scanf("%d%d",&Node[i].lchild,&Node[i].rchild);
    for(int i=0;i<N;i++)//输入N个不同的关键字
        scanf("%d",num+i);
    sort(num,num+N);//对N个关键字从小到大排序
    inorder(0);//零永远是根节点,中序遍历,利用二叉排序树中序遍历结果为从小到大排序,设置给个结点数据域的值
    levelorder(0);//层序遍历,并输出
    return 0;
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值