1037 Magic Coupon (25 分)

本文介绍了一个关于如何在火星魔法商店利用不同优惠券(包括正负数值)获取最大回馈的问题。通过举例说明,解释了如何计算最优组合,例如使用特定优惠券购买商品和免费赠品时的策略。并提供了一段C++代码作为解决方案,该代码计算了可能的最大收益。
摘要由CSDN通过智能技术生成

The magic shop in Mars is offering some magic coupons. Each coupon has an integer N printed on it, meaning that when you use this coupon with a product, you may get N times the value of that product back! What is more, the shop also offers some bonus product for free. However, if you apply a coupon with a positive N to this bonus product, you will have to pay the shop N times the value of the bonus product... but hey, magically, they have some coupons with negative N's!

For example, given a set of coupons { 1 2 4 −1 }, and a set of product values { 7 6 −2 −3 } (in Mars dollars M$) where a negative value corresponds to a bonus product. You can apply coupon 3 (with N being 4) to product 1 (with value M$7) to get M$28 back; coupon 2 to product 2 to get M$12 back; and coupon 4 to product 4 to get M$3 back. On the other hand, if you apply coupon 3 to product 4, you will have to pay M$12 to the shop.

Each coupon and each product may be selected at most once. Your task is to get as much money back as possible.

Input Specification:

Each input file contains one test case. For each case, the first line contains the number of coupons NC​, followed by a line with NC​ coupon integers. Then the next line contains the number of products NP​, followed by a line with NP​ product values. Here 1≤NC​,NP​≤105, and it is guaranteed that all the numbers will not exceed 230.

Output Specification:

For each test case, simply print in a line the maximum amount of money you can get back.

Sample Input:

4
1 2 4 -1
4
7 6 -2 -3

Sample Output:

43

代码: 

#include<iostream>
#include<algorithm>
using namespace std;
bool cmp(int a,int b)//比较函数
{
    return a>b;
}
int main()
{
    int N[2],value[2][100010],P[2],profit=0;//N[2]数组用来存放NC,NP,value[2]用来存放coupon和product,p[2]用来存放正负数的边界的下标
    for(int j=0;j<2;j++)//输入数据
    {
        scanf("%d",&N[j]);
        int i;
        for(i=0;i<N[j];i++)
            scanf("%d",value[j]+i);
        sort(value[j],value[j]+N[j],cmp);//按照大小进行排序
        for(i=0;i<N[j];i++)//查找正负值的边界
            if(value[j][i]<0)
            {
                P[j]=i-1;
                break;
            }
        if(i==N[j])
            P[j]=N[j];
    }
    for(int j=0;j<=P[0]&&j<=P[1];j++)//计算最大收益
        profit+=value[0][j]*value[1][j];
    for(int j=N[0]-1,k=N[1]-1;j>P[0]&&k>P[1];j--,k--)
        profit+=value[0][j]*value[1][k];
    printf("%d",profit);//输出结果
    return 0;
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值