The magic shop in Mars is offering some magic coupons. Each coupon has an integer N printed on it, meaning that when you use this coupon with a product, you may get N times the value of that product back! What is more, the shop also offers some bonus product for free. However, if you apply a coupon with a positive N to this bonus product, you will have to pay the shop N times the value of the bonus product... but hey, magically, they have some coupons with negative N's!
For example, given a set of coupons { 1 2 4 −1 }, and a set of product values { 7 6 −2 −3 } (in Mars dollars M$) where a negative value corresponds to a bonus product. You can apply coupon 3 (with N being 4) to product 1 (with value M$7) to get M$28 back; coupon 2 to product 2 to get M$12 back; and coupon 4 to product 4 to get M$3 back. On the other hand, if you apply coupon 3 to product 4, you will have to pay M$12 to the shop.
Each coupon and each product may be selected at most once. Your task is to get as much money back as possible.
Input Specification:
Each input file contains one test case. For each case, the first line contains the number of coupons NC, followed by a line with NC coupon integers. Then the next line contains the number of products NP, followed by a line with NP product values. Here 1≤NC,NP≤105, and it is guaranteed that all the numbers will not exceed 230.
Output Specification:
For each test case, simply print in a line the maximum amount of money you can get back.
Sample Input:
4
1 2 4 -1
4
7 6 -2 -3
Sample Output:
43
代码:
#include<iostream>
#include<algorithm>
using namespace std;
bool cmp(int a,int b)//比较函数
{
return a>b;
}
int main()
{
int N[2],value[2][100010],P[2],profit=0;//N[2]数组用来存放NC,NP,value[2]用来存放coupon和product,p[2]用来存放正负数的边界的下标
for(int j=0;j<2;j++)//输入数据
{
scanf("%d",&N[j]);
int i;
for(i=0;i<N[j];i++)
scanf("%d",value[j]+i);
sort(value[j],value[j]+N[j],cmp);//按照大小进行排序
for(i=0;i<N[j];i++)//查找正负值的边界
if(value[j][i]<0)
{
P[j]=i-1;
break;
}
if(i==N[j])
P[j]=N[j];
}
for(int j=0;j<=P[0]&&j<=P[1];j++)//计算最大收益
profit+=value[0][j]*value[1][j];
for(int j=N[0]-1,k=N[1]-1;j>P[0]&&k>P[1];j--,k--)
profit+=value[0][j]*value[1][k];
printf("%d",profit);//输出结果
return 0;
}