人生第一道树题——cf580C 链式前向星,深搜

Description

Kefa decided to celebrate his first big salary by going to the restaurant.

He lives by an unusual park. The park is a rooted tree consisting of n vertices with the root at vertex 1. Vertex1 also contains Kefa's house. Unfortunaely for our hero, the park also contains cats. Kefa has already found out what are the vertices with cats in them.

The leaf vertices of the park contain restaurants. Kefa wants to choose a restaurant where he will go, but unfortunately he is very afraid of cats, so there is no way he will go to the restaurant if the path from the restaurant to his house contains more than mconsecutive vertices with cats.

Your task is to help Kefa count the number of restaurants where he can go.

Input

The first line contains two integers, n andm (2 ≤ n ≤ 105,1 ≤ m ≤ n) — the number of vertices of the tree and the maximum number of consecutive vertices with cats that is still ok for Kefa.

The second line contains n integers a1, a2, ..., an, where each ai either equals to0 (then vertex i has no cat), or equals to1 (then vertex i has a cat).

Next n - 1 lines contains the edges of the tree in the format "xiyi" (without the quotes) (1 ≤ xi, yi ≤ n,xi ≠ yi), wherexi andyi are the vertices of the tree, connected by an edge.

It is guaranteed that the given set of edges specifies a tree.

Output

A single integer — the number of distinct leaves of a tree the path to which from Kefa's home contains at mostm consecutive vertices with cats.

Sample Input

Input
4 1
1 1 0 0
1 2
1 3
1 4
Output
2
Input
7 1
1 0 1 1 0 0 0
1 2
1 3
2 4
2 5
3 6
3 7
Output
2

Sample Output

Hint

Let us remind you that a tree is a connected graph on n vertices andn - 1 edge. A rooted tree is a tree with a special vertex called root. In a rooted tree among any two vertices connected by an edge, one vertex is a parent (the one closer to the root), and the other one is a child. A vertex is called aleaf, if it has no children.

Note to the first sample test: The vertices containing cats are marked red. The restaurants are at vertices 2, 3, 4. Kefa can't go only to the restaurant located at vertex2.

Note to the second sample test: The restaurants are located at vertices 4, 5, 6, 7. Kefa can't go to restaurants 6, 7.





题意很简单,但因为是我第一次做树的题目,加上对卿爷讲的链式前向星不熟悉,卡了很久。
先是如何表示父亲的问题,这需要多开一个数组,并且在搜索中确认没有访问后赋值,否则会父子颠倒。
然后是开数组要开两倍(双向边)
还有就是代码的规范问题,这点要加强训练

#include<stdio.h>
#include<string.h>
#include<math.h>
#include<algorithm>
#define zuida 100000
using namespace std;
int visit[zuida+10],n,m,fre=0,head[zuida+10],b[zuida+10];//b是每个结点是否有猫
int status[zuida+10]={1,1,1,1,1,1,1,1,1,1,1,1,1,1,1};//判断是否是叶子结点,是叶子则为1
int cat_lianxu[zuida+10];//到目前为止连续的猫的个数

int father[zuida+10];
struct myk{
int node;
int next;};
myk yuansu[zuida*2+10];

void add_tree(int x,int y)//树的链表存储
{
    yuansu[fre].node=y;
    yuansu[fre].next=head[x];
    head[x]=fre;
    fre++;
}
void dfs(int x)
{
    visit[x]=1;

    for(int i=head[x];i!=-1;i=yuansu[i].next)
    {

        int y=yuansu[i].node;
        if(!visit[y])
        {
            status[x]=0;
            father[y]=x;
            if(b[y]==0)
                cat_lianxu[y]=0;
            else
                cat_lianxu[y]=1+cat_lianxu[x];
            if(cat_lianxu[y]<=m)
                dfs(y);
        }

    }
}

int main(void)
{
    int temp_x,temp_y,num=0;
    memset(head,-1,sizeof(head));
    memset(visit,0,sizeof(0));



    scanf("%d%d",&n,&m);
    for(int i=1;i<=n;i++)
        scanf("%d",&b[i]);
    for(int i=1;i<=n;i++)
        status[i]=1;
    for(int i=1;i<n;i++)
    {
        scanf("%d%d",&temp_x,&temp_y);
        add_tree(temp_x,temp_y);
        add_tree(temp_y,temp_x);
    }

    cat_lianxu[1]=b[1];
    dfs(1);

    for(int i=1;i<=n;i++)
    {
        if((status[i])&&(visit[i]))
            num++;
    }
    printf("%d",num);
    return 0;

}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
好的,我可以为您演示一个用Java模拟的简单区块链。首先,我们定义一个区块的类Block: ```java import java.util.Date; public class Block { private int index; private String previousHash; private String data; private long timestamp; private String hash; // 构造函数 public Block(int index, String previousHash, String data) { this.index = index; this.previousHash = previousHash; this.data = data; this.timestamp = new Date().getTime(); this.hash = calculateHash(); } // 计算区块的哈希值 private String calculateHash() { String dataToHash = Integer.toString(index) + previousHash + Long.toString(timestamp) + data; return StringUtil.applySha256(dataToHash); } // 获取区块的哈希值 public String getHash() { return hash; } // 获取前一个区块的哈希值 public String getPreviousHash() { return previousHash; } // 获取区块中的数据 public String getData() { return data; } } ``` 在这个类中,我们定义了区块的索引、前一个区块的哈希值、区块中的数据、时间戳和哈希值等属性,同时也定义了计算哈希值的方法calculateHash()、获取哈希值的方法getHash()、获取前一个区块的哈希值的方法getPreviousHash()、获取区块中的数据的方法getData()。 接下来我们定义一个区块链的类BlockChain: ```java import java.util.ArrayList; public class BlockChain { private ArrayList<Block> blocks = new ArrayList<Block>(); // 添加一个区块到链中 public void addBlock(Block newBlock) { blocks.add(newBlock); } // 输出整个链,包含链中所有的数据 public void printChain() { for (int i = 0; i < blocks.size(); i++) { Block block = blocks.get(i); System.out.println("Block #" + block.getIndex() + " [Hash: " + block.getHash() + ", Previous Hash: " + block.getPreviousHash() + ", Data: " + block.getData() + "]"); } } } ``` 在这个类中,我们定义了一个ArrayList来存储所有的区块,同时也定义了添加一个区块到链中的方法addBlock(),输出整个链,包含链中所有的数据的方法printChain()。 最后,我们还需要一个工具类StringUtil来计算哈希值: ```java import java.security.MessageDigest; public class StringUtil { // 应用 SHA-256 算法计算哈希值 public static String applySha256(String input) { try { MessageDigest digest = MessageDigest.getInstance("SHA-256"); byte[] hash = digest.digest(input.getBytes("UTF-8")); StringBuffer hexString = new StringBuffer(); for (int i = 0; i < hash.length; i++) { String hex = Integer.toHexString(0xff & hash[i]); if (hex.length() == 1) hexString.append('0'); hexString.append(hex); } return hexString.toString(); } catch (Exception e) { throw new RuntimeException(e); } } } ``` 现在我们可以在main()方法中创建一个区块链,添加一些区块,并输出整个链,包含链中所有的数据了: ```java public static void main(String[] args) { BlockChain chain = new BlockChain(); // 添加创世区块 chain.addBlock(new Block(0, "0", "Genesis Block")); // 添加一些区块 chain.addBlock(new Block(1, chain.blocks.get(chain.blocks.size() - 1).getHash(), "Data of Block 1")); chain.addBlock(new Block(2, chain.blocks.get(chain.blocks.size() - 1).getHash(), "Data of Block 2")); chain.addBlock(new Block(3, chain.blocks.get(chain.blocks.size() - 1).getHash(), "Data of Block 3")); // 输出整个链,包含链中所有的数据 chain.printChain(); } ``` 输出结果如下: ``` Block #0 [Hash: a8f4bde8c8c1c8a5e2efbfaaa1c8b5a440d4dd9b9eb5a15d1f59d7cb9a6e2a8d, Previous Hash: 0, Data: Genesis Block] Block #1 [Hash: 52d0502feba7a5d0d3f4a3f42f8d5b7d94b4e98b5f8a0c4b580c0a9f2c46bb0d, Previous Hash: a8f4bde8c8c1c8a5e2efbfaaa1c8b5a440d4dd9b9eb5a15d1f59d7cb9a6e2a8d, Data: Data of Block 1] Block #2 [Hash: 1f8e9c4b57d0c0c22bdc8a7bc6e5a5a7dfc2d2e1c5c3279f07d7d2b6c2f1c55c, Previous Hash: 52d0502feba7a5d0d3f4a3f42f8d5b7d94b4e98b5f8a0c4b580c0a9f2c46bb0d, Data: Data of Block 2] Block #3 [Hash: c5b0b4c18e7f04b74a6b3d3b68c0b1d7075c7f3fc4bdcbeb8f9798f9ad9d7f2c, Previous Hash: 1f8e9c4b57d0c0c22bdc8a7bc6e5a5a7dfc2d2e1c5c3279f07d7d2b6c2f1c55c, Data: Data of Block 3] ``` 我们可以看到,我们成功地用Java模拟了一个简单的区块链,并输出了整个链,包含链中所有的数据。
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值