joj 1270

1270: Triangle Wave


ResultTIME LimitMEMORY LimitRun TimesAC TimesJUDGE
3s8192K1339684Standard

In this problem you are to generate a triangular wave form according to a specified pair of Amplitude and Frequency.

Input and Output

The input will contain two integers, each on a separate line. The first integer is the Amplitude; the second integer is the Frequency.

For the output of your program, you will be printing wave forms each separated by a blank line. The total number of wave forms equals the Frequency, and the horizontal ``height'' of each wave equals the Amplitude. The Amplitude will never be greater than nine.

The waveform itself should be filled with integers on each line which indicate the ``height'' of that line.

NOTE: There is a blank line after each separate waveform, excluding the last one.

Sample Input

3
2

Sample Output

1
22
333
22
1

1
22
333
22
1

 

 #include<cstdio>
void out(int n)
{
 int i,j;
    for(i=1;i<=n;i++)
    {
        for(j=1;j<=i;j++)printf("%d",i);
        printf("\n");
    }
    for(i=n-1;i>=1;i--)
    {
        for(j=1;j<=i;j++)printf("%d",i);
        printf("\n");
    }
}
int main()
{
    int m,n,i;
    scanf("%d%d",&m,&n);
    for(i=0;i<n;i++)
    {
        if(i!=0)printf("\n");
        out(m);
    }
    return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值