HDU 1698 Just a Hook 数据结构+线段树+区间修改(设值)+区间求和

HDU 1698 Just a Hook
Time Limit:2000MS    Memory Limit:32768KB    64bit IO Format:%I64d & %I64u

Description

In the game of DotA, Pudge’s meat hook is actually the most horrible thing for most of the heroes. The hook is made up of several consecutive metallic sticks which are of the same length.



Now Pudge wants to do some operations on the hook.

Let us number the consecutive metallic sticks of the hook from 1 to N. For each operation, Pudge can change the consecutive metallic sticks, numbered from X to Y, into cupreous sticks, silver sticks or golden sticks.
The total value of the hook is calculated as the sum of values of N metallic sticks. More precisely, the value for each kind of stick is calculated as follows:

For each cupreous stick, the value is 1.
For each silver stick, the value is 2.
For each golden stick, the value is 3.

Pudge wants to know the total value of the hook after performing the operations.
You may consider the original hook is made up of cupreous sticks.
 

Input

The input consists of several test cases. The first line of the input is the number of the cases. There are no more than 10 cases.
For each case, the first line contains an integer N, 1<=N<=100,000, which is the number of the sticks of Pudge’s meat hook and the second line contains an integer Q, 0<=Q<=100,000, which is the number of the operations.
Next Q lines, each line contains three integers X, Y, 1<=X<=Y<=N, Z, 1<=Z<=3, which defines an operation: change the sticks numbered from X to Y into the metal kind Z, where Z=1 represents the cupreous kind, Z=2 represents the silver kind and Z=3 represents the golden kind.
 

Output

For each case, print a number in a line representing the total value of the hook after the operations. Use the format in the example.
 

Sample Input

    
    
1 10 2 1 5 2 5 9 3
 

Sample Output

  
  
Case 1: The total value of the hook is 24. 解题思路: 题目以一个游戏为背景,但是描述很清楚,就是区间设值,然后求区间的和 1,这题用的是刘汝佳的大白《训练指南》里面的代码 2,仔细观察我的代码,其实我的代码在实现求和的同时,也实现了区间极值的维护 3,这个代码从某种程度上算作是模板,但是想实际利用不容易。
#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
#include<cmath>
using namespace std;
const int maxn = 100005 ;
int n ;
int YI,YII,v;
int _min,_max,_sum ;
int maxv[4*maxn];
int minv[4*maxn];
int sumv[4*maxn];
int setv[4*maxn];
void maintain(int o,int L,int R){
    int lc = o*2,rc = o*2+1 ;
    sumv[o] = minv[o] = maxv[o] = 0 ;
    if(R>L){
        sumv[o] = sumv[lc] + sumv[rc] ;
        minv[o] = min(minv[lc],minv[rc]);
        maxv[o] = max(maxv[lc],maxv[rc]);
    }
    if(setv[o]>0){
        minv[o]=setv[o] ;
        maxv[o]=setv[o] ;
        sumv[o]=setv[o]*(R-L+1) ;
    }
}
void pushdown(int o){
    int lc = o*2 ;
    int rc = o*2+1 ;
    if(setv[o]>=0){
        setv[lc] = setv[rc] = setv[o] ;
        setv[o] = -1 ;
    }
}
void update(int o,int L,int R){
    int lc = o*2 ;
    int rc = o*2+1 ;
    if(YI<=L&&YII>=R){
        setv[o] = v ;
    }else{
        pushdown(o) ;
        int M = L+(R-L)/2 ;
        if(YI<=M){
            update(lc,L,M) ;
        }else{
            maintain(lc,L,M) ;
        }
        if(YII>M){
            update(rc,M+1,R) ;
        }else {
            maintain(rc,M+1,R) ;
        }
    }
    maintain(o,L,R) ;
}
void query(int o,int L,int R){
    if(setv[o]>=0){
        _sum += setv[o]*(min(R,YII)-max(L,YI)+1) ;
        _min = min(_min,setv[o]) ;
        _max = max(_max,setv[o]) ;
    }else if(YI<=L&&YII>=R){
        _sum+=sumv[o] ;
        _min = min(_min,minv[o]) ;
        _max = max(_max,maxv[o]) ;
    }else{
        int M = L + (R-L)/2 ;
        if(YI<=M)query(o*2,L,M) ;
        if(YII>M)query(o*2+1,M+1,R) ;
    }
}
void init() {
    memset(maxv,-1,sizeof(maxv)) ;
    memset(minv,0,sizeof(minv)) ;
    memset(sumv,0,sizeof(sumv)) ;
    memset(setv,-1,sizeof(setv)) ;
    _sum = 0 ;
    _max = -1 ;
    _min = 0x3f3f3f3f ;
}
void reset(){
    _sum = 0 ;
    _max = -1 ;
    _min = 0x3f3f3f3f ;
}
int main(){
    int T ;
    int cas =1 ;
    //freopen("in.txt","r",stdin);
    scanf("%d",&T);
    while(T--){
        init();
        scanf("%d",&n);
        YI = 1 ;YII = n ;v = 1 ;///初始化
        update(1,1,n) ;
        int m ;
        scanf("%d",&m);
        for(int i=0;i<m;i++){///m次更改区间
            scanf("%d%d%d",&YI,&YII,&v);
            update(1,1,n) ;
        }
        YI = 1;YII = n;
        query(1,1,n) ;
        printf("Case %d: The total value of the hook is %d.\n",cas++,_sum) ;
    }
    return 0;
}


 
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值