1058. A+B in Hogwarts (20)

389 篇文章 1 订阅
140 篇文章 0 订阅

1058. A+B in Hogwarts (20)
时间限制 50 ms 内存限制 65536 kB 代码长度限制 16000 B
判题程序 Standard 作者 CHEN, Yue

If you are a fan of Harry Potter, you would know the world of magic has its own currency system – as Hagrid explained it to Harry, “Seventeen silver Sickles to a Galleon and twenty-nine Knuts to a Sickle, it’s easy enough.” Your job is to write a program to compute A+B where A and B are given in the standard form of “Galleon.Sickle.Knut” (Galleon is an integer in [0, 107], Sickle is an integer in [0, 17), and Knut is an integer in [0, 29)).
Input Specification:
Each input file contains one test case which occupies a line with A and B in the standard form, separated by one space.
Output Specification:
For each test case you should output the sum of A and B in one line, with the same format as the input.
Sample Input:
3.2.1 10.16.27
Sample Output:
14.1.28

#define _CRT_SECURE_NO_WARNINGS
#include <iostream>
#include <fstream>
#include <string>
#include <cmath>
#include <algorithm>
#include <queue>
using namespace std;

typedef struct
{
    unsigned long long G;
    unsigned int S;
    unsigned int K;
}M;

int main()
{
#ifdef _DEBUG
    freopen("data.txt", "r+", stdin);
    //fstream cin("data.txt");
#endif // _DEBUG

    M A, B, res;
    res.G = res.S = res.K = 0;
    scanf("%llu.%u.%u %llu.%u.%u", &A.G, &A.S, &A.K, &B.G, &B.S, &B.K);
    res.K = (A.K + B.K >= 29) ? (res.S += 1, A.K + B.K - 29) : (A.K + B.K);
    res.S = (res.S + A.S + B.S >= 17) ? (res.G += 1, res.S + A.S + B.S - 17) : (res.S + A.S + B.S);  //特别注意这里的进位,第一遍被我写丢了res.S,没考虑之前进上来的位。
    res.G += A.G + B.G;
    printf("%llu.%u.%u", res.G, res.S, res.K);
#ifdef _DEBUG
    //cin.close();
#ifndef _CODEBLOCKS
    system("pause");
#endif // !_CODEBLOCKS
#endif // _DEBUG

    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值