问题 A: 求第k大数

389 篇文章 1 订阅
144 篇文章 2 订阅

问题 A: 求第k大数
时间限制: 1 Sec 内存限制: 128 MB
献花: 109 解决: 42
[献花][花圈][TK题库]
题目描述

求第k大的数
(Kth.pas/c/cpp)

给定一个长度为n(1≤n≤1,000,000)的无序正整数序列,以及另一个数k(1≤k≤1,000,000)(关于第k大的数:例如序列{1,2,3,4,5,6}中第3大的数是4。)
输入
第一行两个正整数m,n。
第二行为n个正整数。
输出
第k大的数。
样例输入
6 3
1 2 3 4 5 6
样例输出
4

#define _CRT_SECURE_NO_WARNINGS
#include <iostream>
#include <cstring>
#include <fstream>
#include <string>
#include <cmath>
#include <algorithm>
#include <queue>
#include <ctime>
using namespace std;


int BinaryFindK(int a[], int L, int R,int K)
{
    int pos = round((double)rand() / RAND_MAX * (R - L)) + L,tmp ,TL = L,TR = R;
    tmp = a[pos]; a[pos] = a[TL];

    while (TL < TR)
    {
        while (TL < TR && a[TR] <= tmp) TR--;
        a[TL] = a[TR];
        while (TL < TR&&a[TL] >= tmp) TL++;
        a[TR] = a[TL];
    }
    a[TL] = tmp;
    if (TL == K)
        return a[TL];
    else if (TL > K)
        return BinaryFindK(a, L, TL - 1, K);
    else return BinaryFindK(a, TL + 1, R, K);
}


int main()
{
#ifdef _DEBUG
    freopen("data.txt", "r+", stdin);
    //fstream cin("data.txt");
#endif // _DEBUG

    const unsigned int MaxN = 100010;
    bool flag[MaxN];
    int Data[MaxN];
    srand((unsigned int)time(NULL));
    int K, n, tmp, Num = 0;

    while(~scanf("%d %d", &n, &K))
    {
        for (int i = 0; i < n; ++i)
        {
            scanf("%d", &tmp);
            if (!flag[tmp])
            {
                Data[Num++] = tmp;
                flag[tmp] = true;
            }
        }

        //sort(Data, Data + Num,cmp);
        //printf("%d\n", Data[K-1]);
        int res = BinaryFindK(Data, 0, Num - 1, K - 1);
        printf("%d", res);
    }



#ifdef _DEBUG
    //cin.close();
#ifndef _CODEBLOCKS
    system("pause");
#endif // !_CODEBLOCKS
#endif // _DEBUG

    return 0;
}

/**************************************************************
    Problem: 5067
    User: Sharwen
    Language: C++
    Result: 升仙
    Time:1 ms
    Memory:2072 kb
****************************************************************/
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值