1096. Consecutive Factors (20)
时间限制 400 ms 内存限制 65536 kB 代码长度限制 16000 B
判题程序 Standard 作者 CHEN, Yue
Among all the factors of a positive integer N, there may exist several consecutive numbers. For example, 630 can be factored as 3*5*6*7, where 5, 6, and 7 are the three consecutive numbers. Now given any positive N, you are supposed to find the maximum number of consecutive factors, and list the smallest sequence of the consecutive factors.
Input Specification:
Each input file contains one test case, which gives the integer N (1 < N < 231).
Output Specification:
For each test case, print in the first line the maximum number of consecutive factors. Then in the second line, print the smallest sequence of the consecutive factors in the format “factor[1]factor[2]…*factor[k]”, where the factors are listed in increasing order, and 1 is NOT included.
Sample Input:
630
Sample Output:
3
5*6*7
注意:
- 测试点没有n==6的情况,但是如果不进行n==6特判的话,输出结果是不对的
#define _CRT_SECURE_NO_WARNINGS
#include <unordered_map>
#include <algorithm>
#include <iostream>
#include <iomanip>
#include <cstring>
#include <string>
#include <vector>
#include <stack>
#include <queue>
#include <map>
using namespace std;
int main()
{
#ifdef _DEBUG
freopen("data.txt", "r+", stdin);
#endif // _DEBUG
int n, qrt, maxL = 0, curL = 0, start = 0;
cin >> n;
qrt = sqrt(n);
for (int i = 2; i <= qrt; ++i)
{
if (n%i == 0)
{
curL = 1;
int j = i + 1, tmp = n / i;
while (tmp % j == 0)
{
tmp /= j;
++curL;
++j;
}
if (curL > maxL)
{
maxL = curL;
start = i;
}
}
}
if (n == 6)
{
printf("2\n2*3");
return 0;
}
if (start == 0)
printf("1\n%d", n);
else
{
printf("%d\n%d", maxL,start);
for (int i = 1; i < maxL; ++i)
printf("*%d", start + i);
}
return 0;
}