1025. 反转链表 (25)

389 篇文章 1 订阅
72 篇文章 0 订阅

1025. 反转链表 (25)
时间限制 300 ms 内存限制 65536 kB 代码长度限制 8000 B
判题程序 Standard 作者 CHEN, Yue

给定一个常数K以及一个单链表L,请编写程序将L中每K个结点反转。例如:给定L为1→2→3→4→5→6,K为3,则输出应该为3→2→1→6→5→4;如果K为4,则输出应该为4→3→2→1→5→6,即最后不到K个元素不反转。
输入格式:
每个输入包含1个测试用例。每个测试用例第1行给出第1个结点的地址、结点总个数正整数N(<= 105)、以及正整数K(<=N),即要求反转的子链结点的个数。结点的地址是5位非负整数,NULL地址用-1表示。
接下来有N行,每行格式为:
Address Data Next
其中Address是结点地址,Data是该结点保存的整数数据,Next是下一结点的地址。
输出格式:
对每个测试用例,顺序输出反转后的链表,其上每个结点占一行,格式与输入相同。
输入样例:
00100 6 4
00000 4 99999
00100 1 12309
68237 6 -1
33218 3 00000
99999 5 68237
12309 2 33218
输出样例:
00000 4 33218
33218 3 12309
12309 2 00100
00100 1 99999
99999 5 68237
68237 6 -1

#define _CRT_SECURE_NO_WARNINGS
#include <algorithm>
#include <functional>
#include <iostream>
#include <queue>

using namespace std;
const int MaxN = 100010;

struct Slinklist
{
    int data;
    int nextAddr;
}SLT[MaxN] = {-1};

struct info
{
    int Addr;
    int data;
    int nextAddr;
}ans[MaxN];

int AddrStore[MaxN], n = 0;

int main()
{
#ifdef _DEBUG
    freopen("data.txt", "r+", stdin);
#endif

    //std::ios::sync_with_stdio(false);

    int startAddr, N, K, Addr;
    scanf("%d %d %d", &startAddr, &N, &K);

    while (N--)
    {
        scanf("%d", &Addr);
        scanf("%d %d", &SLT[Addr].data, &SLT[Addr].nextAddr);
    }

    Addr = startAddr;

    while (Addr != -1)
    {
        int idx = 0;
        for (int i = 0; i < K && Addr != -1; ++i)
        {
            AddrStore[i] = Addr;
            Addr = SLT[Addr].nextAddr;
            ++idx;
        }


        for (int i = 0; i < idx; ++i, ++n)
        {
            if (idx == K)
            {
                ans[n].data = SLT[AddrStore[idx - i - 1]].data;
                ans[n].Addr = AddrStore[idx - i - 1];
            }
            else
            {
                ans[n].data = SLT[AddrStore[i]].data;
                ans[n].Addr = AddrStore[i];
            }

            if (i != idx - 1)
            {
                if (K == idx)
                    ans[n].nextAddr = AddrStore[idx - i - 2];
                else
                    ans[n].nextAddr = SLT[AddrStore[i]].nextAddr;
            }
            else if (Addr != -1)
            {
                int tmp = Addr, i = 0;
                for (; i < K-1 && SLT[tmp].nextAddr != -1; ++i)
                {
                    tmp = SLT[tmp].nextAddr;
                }
                if (i == K - 1)
                    ans[n].nextAddr = tmp;
                else
                    ans[n].nextAddr = Addr;
            }
            else
                ans[n].nextAddr = -1;
        }
    }

    for (int i = 0; i < n; ++i)
    {
        printf("%05d %d ",ans[i].Addr,ans[i].data);
        if (ans[i].nextAddr != -1)
            printf("%05d\n", ans[i].nextAddr);
        else
            printf("-1\n");
    }

    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值