1123. Is It a Complete AVL Tree (30)

389 篇文章 1 订阅
140 篇文章 0 订阅

1123. Is It a Complete AVL Tree (30)
时间限制 400 ms 内存限制 65536 kB 代码长度限制 16000 B
判题程序 Standard 作者 CHEN, Yue

An AVL tree is a self-balancing binary search tree. In an AVL tree, the heights of the two child subtrees of any node differ by at most one; if at any time they differ by more than one, rebalancing is done to restore this property. Figures 1-4 illustrate the rotation rules.

这里写图片描述
这里写图片描述
这里写图片描述
这里写图片描述

Now given a sequence of insertions, you are supposed to output the level-order traversal sequence of the resulting AVL tree, and to tell if it is a complete binary tree.
Input Specification:
Each input file contains one test case. For each case, the first line contains a positive integer N (<= 20). Then N distinct integer keys are given in the next line. All the numbers in a line are separated by a space.
Output Specification:
For each test case, insert the keys one by one into an initially empty AVL tree. Then first print in a line the level-order traversal sequence of the resulting AVL tree. All the numbers in a line must be separated by a space, and there must be no extra space at the end of the line. Then in the next line, print “YES” if the tree is complete, or “NO” if not.
Sample Input 1:
5
88 70 61 63 65
Sample Output 1:
70 63 88 61 65
YES
Sample Input 2:
8
88 70 61 96 120 90 65 68
Sample Output 2:
88 65 96 61 70 90 120 68
NO

#define _CRT_SECURE_NO_WARNINGS
#include <algorithm>
#include <iostream>
#include <queue>

using namespace std;
const int MaxN = 22;
int N,Count = 0;

typedef struct tnode
{
    int val;
    int hight;
    struct tnode * lchild;
    struct tnode * rchild;
}TNode, *PTNode;

int GetHight(PTNode root)
{
    if (root == nullptr) return 0;
    return root->hight;
}

int GetBalanceFac(PTNode root)
{
    return GetHight(root->lchild) - GetHight(root->rchild);
}

void updateHight(PTNode root)
{
    root->hight = max(GetHight(root->lchild), GetHight(root->rchild)) + 1;
}

void R_Rotate(PTNode &root)
{
    PTNode tmp = root->lchild;
    root->lchild = tmp->rchild;
    tmp->rchild = root;

    updateHight(root);
    updateHight(tmp);
    root = tmp;
}

void L_Rotate(PTNode &root)
{
    PTNode tmp = root->rchild;
    root->rchild = tmp->lchild;
    tmp->lchild = root;

    updateHight(root);
    updateHight(tmp);
    root = tmp;
}


void InsertNode(PTNode  &root, int value)
{
    if (!root)
    {
        root = new TNode;
        root->val = value;
        root->hight = 1;
        root->lchild = root->rchild = nullptr;
    }
    else if (value < root->val)
    {
        InsertNode(root->lchild, value);
        updateHight(root);
        if (GetBalanceFac(root) == 2)
        {
            int bfc = GetBalanceFac(root->lchild);
            if (bfc == 1)
                R_Rotate(root);
            else if (bfc == -1)
            {
                L_Rotate(root->lchild);
                R_Rotate(root);
            }
        }
    }
    else
    {
        InsertNode(root->rchild, value);
        updateHight(root);
        if (GetBalanceFac(root) == -2)
        {
            int bfc = GetBalanceFac(root->rchild);
            if (bfc == -1)
                L_Rotate(root);
            else if (bfc == 1)
            {
                R_Rotate(root->rchild);
                L_Rotate(root);
            }
        }
    }

}


PTNode CreateAVL(int n, int data[])
{
    PTNode root = nullptr;
    for (int i = 0; i < n; ++i)
        InsertNode(root, data[i]);

    return root;
}

void LevelOrder(PTNode root)
{
    if (root == nullptr) return;
    queue<PTNode> que; que.push(root);

    while (que.size())
    {
        PTNode node = que.front(); que.pop();

        if (node->lchild != nullptr)que.push(node->lchild);
        if (node->rchild != nullptr)que.push(node->rchild);
        ++Count;
        cout << node->val;
        if (Count != N)
            cout << " ";
    }
}

bool isCBT(PTNode root)
{
    if (root == nullptr) return false;
    queue<PTNode> que; que.push(root);

    while (que.size())
    {
        PTNode node = que.front(); que.pop();
        if (node != nullptr)
        {
            que.push(node->lchild);
            que.push(node->rchild);
        }
        else
            break;
    }

    while (que.size())
    {
        PTNode node = que.front(); que.pop();
        if (node != nullptr)
            return false;
    }
    return true;
}

int main()
{
#ifdef _DEBUG
    freopen("data.txt", "r+", stdin);
#endif // _DEBUG

    std::ios::sync_with_stdio(false);

    int data[MaxN];
    cin >> N;
    for (int i = 0; i < N; ++i)
        cin >> data[i];

    PTNode root = CreateAVL(N, data);

    LevelOrder(root);

    isCBT(root) ? (cout << "\nYES") : (cout << "\nNO");
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值