1079. 延迟的回文数 (20)

389 篇文章 1 订阅
72 篇文章 0 订阅

1079. 延迟的回文数 (20)
时间限制 400 ms 内存限制 65536 kB 代码长度限制 8000 B
判题程序 Standard 作者 CHEN, Yue

给定一个 k+1 位的正整数 N,写成 ak…a1a0 的形式,其中对所有 i 有 0 <= ai < 10 且 ak > 0。N 被称为一个回文数,当且仅当对所有 i 有 ai = ak-i。零也被定义为一个回文数。
非回文数也可以通过一系列操作变出回文数。首先将该数字逆转,再将逆转数与该数相加,如果和还不是一个回文数,就重复这个逆转再相加的操作,直到一个回文数出现。如果一个非回文数可以变出回文数,就称这个数为延迟的回文数。(定义翻译自 https://en.wikipedia.org/wiki/Palindromic_number
给定任意一个正整数,本题要求你找到其变出的那个回文数。
输入格式:
输入在一行中给出一个不超过1000位的正整数。
输出格式:
对给定的整数,一行一行输出其变出回文数的过程。每行格式如下
A + B = C
其中A是原始的数字,B是A的逆转数,C是它们的和。A从输入的整数开始。重复操作直到C在10步以内变成回文数,这时在一行中输出“C is a palindromic number.”;或者如果10步都没能得到回文数,最后就在一行中输出“Not found in 10 iterations.”。
输入样例 1:
97152
输出样例 1:
97152 + 25179 = 122331
122331 + 133221 = 255552
255552 is a palindromic number.
输入样例 2:
196
输出样例 2:
196 + 691 = 887
887 + 788 = 1675
1675 + 5761 = 7436
7436 + 6347 = 13783
13783 + 38731 = 52514
52514 + 41525 = 94039
94039 + 93049 = 187088
187088 + 880781 = 1067869
1067869 + 9687601 = 10755470
10755470 + 07455701 = 18211171
Not found in 10 iterations.

注意点:如果输入的本身就是回文数,直接输出,不用计算了

#define _CRT_SECURE_NO_WARNINGS
#include <algorithm>
#include <iostream>
#include <string>
#include <cstring>
#include <iomanip>

using namespace std;
const int MaxN = 10000;

void add(char res[], char a[])
{
    int len = strlen(res), jinw = 0, i = 0;
    for (; i < len; ++i)
    {
        int num = res[i] + a[i] - 2 * '0' + jinw;
        res[i] = num % 10 + '0';
        jinw = num / 10;
    }
    if (jinw)res[i] = jinw + '0';
    res[i + 1] = 0;
}

bool isPalindromic(char num[], int len)
{
    int left = 0, right = len - 1;
    while (left < right)
    {
        if (num[left++] != num[right--]) return false;
    }
    return true;
}

int main()
{
#ifdef _DEBUG
    freopen("data.txt", "r+", stdin);
#endif // _DEBUG
    std::ios::sync_with_stdio(false);

    char res[MaxN], a[MaxN];
    cin >> res;

    if (isPalindromic(res, strlen(res)))
    {
        cout << res << " is a palindromic number.";
        return 0;
    }

    strcpy(a, res);
    reverse(a, a + strlen(res));
    for (int i = 0; i < 10; ++i)
    {
        cout << res << " + " << a << " = ";
        add(res, a);
        strcpy(a, res);

        int resLen = strlen(res);
        reverse(res, res + resLen);
        cout << res << endl;

        if (isPalindromic(res,resLen))
        {
            cout << res << " is a palindromic number.";
            return 0;
        }
    }
    cout << "Not found in 10 iterations.";
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值