1105. Spiral Matrix (25)

389 篇文章 1 订阅
140 篇文章 0 订阅

1105. Spiral Matrix (25)
时间限制 150 ms 内存限制 65536 kB 代码长度限制 16000 B
判题程序 Standard 作者 CHEN, Yue

This time your job is to fill a sequence of N positive integers into a spiral matrix in non-increasing order. A spiral matrix is filled in from the first element at the upper-left corner, then move in a clockwise spiral. The matrix has m rows and n columns, where m and n satisfy the following: m*n must be equal to N; m>=n; and m-n is the minimum of all the possible values.
Input Specification:
Each input file contains one test case. For each case, the first line gives a positive integer N. Then the next line contains N positive integers to be filled into the spiral matrix. All the numbers are no more than 104. The numbers in a line are separated by spaces.
Output Specification:
For each test case, output the resulting matrix in m lines, each contains n numbers. There must be exactly 1 space between two adjacent numbers, and no extra space at the end of each line.
Sample Input:
12
37 76 20 98 76 42 53 95 60 81 58 93
Sample Output:
98 95 93
42 37 81
53 20 76
58 60 76

#define _CRT_SECURE_NO_WARNINGS
#include <algorithm>
#include <iostream>
#include <iomanip>

using namespace std;
const int MaxN = 10010;
int Metrix[MaxN][MaxN];

int main()
{
#ifdef _DEBUG
    freopen("data.txt", "r+", stdin);
#endif // _DEBUG
    std::ios::sync_with_stdio(false);

    int N,m,n,Product,data[MaxN];
    cin >> N;

    for (int i = 0; i < N; ++i)cin >> data[i];
    sort(data, data + N, [](int a, int b) {return a > b; });

    m = n = sqrt(N);
    Product = m * n;
    while (Product != N)//计算m 与 n
    {
        if (Product > N)--n;
        else ++m;
        Product = m * n;
    }

    int left = 0, right = n - 1, up = 0, down = m - 1,idx = 0;
    while (idx < N)//一次填完一个圈
    {
        int curC = left;
        while (curC <= right)Metrix[up][curC++] = data[idx++];
        ++up;//填完上方的一行
        if (idx >= N)break;

        int curL = up;
        while (curL <= down)Metrix[curL++][right] = data[idx++];
        --right;//填完最右边的一列
        if (idx >= N)break;

        curC = right;
        while (curC >= left)Metrix[down][curC--] = data[idx++];
        --down;//填完最下方的一行
        if (idx >= N)break;

        curL = down;
        while (curL >= up)Metrix[curL--][left] = data[idx++];
        ++left;//填完最左边的一行
    }

    for (int i = 0; i < m; ++i)
    {
        for (int k = 0; k < n; ++k)
        {
            cout << Metrix[i][k];
            if (k != n - 1)cout << " ";
        }
        cout << endl;
    }

    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值