1112. Stucked Keyboard (20)

389 篇文章 1 订阅
140 篇文章 0 订阅

1112. Stucked Keyboard (20)
时间限制 400 ms 内存限制 65536 kB 代码长度限制 16000 B
判题程序 Standard 作者 CHEN, Yue

On a broken keyboard, some of the keys are always stucked. So when you type some sentences, the characters corresponding to those keys will appear repeatedly on screen for k times.
Now given a resulting string on screen, you are supposed to list all the possible stucked keys, and the original string.
Notice that there might be some characters that are typed repeatedly. The stucked key will always repeat output for a fixed k times whenever it is pressed. For example, when k=3, from the string “thiiis iiisss a teeeeeest” we know that the keys “i” and “e” might be stucked, but “s” is not even though it appears repeatedly sometimes. The original string could be “this isss a teest”.
Input Specification:
Each input file contains one test case. For each case, the 1st line gives a positive integer k(大于1小于等于100 ) which is the output repeating times of a stucked key. The 2nd line contains the resulting string on screen, which consists of no more than 1000 characters from {a-z}, {0-9} and “_”. It is guaranteed that the string is non-empty.
Output Specification:
For each test case, print in one line the possible stucked keys, in the order of being detected. Make sure that each key is printed once only. Then in the next line print the original string. It is guaranteed that there is at least one stucked key.
Sample Input:
3
caseee1__thiiis_iiisss_a_teeeeeest
Sample Output:
ei
case1__this_isss_a_teest

可能的坑点:如果有连续n(n>k)个字符,如果不是k的倍数,同样键盘是有效的

#define _CRT_SECURE_NO_WARNINGS
#include <algorithm>
#include <iostream>
#include <string>

using namespace std;
const int MaxN = 256;
bool hashTable[MaxN];
bool hashTraverse[MaxN];
bool isPrint[MaxN];


void Stucked(bool isSame,char ch, int &n ,int k) {
    if (isSame) ++n;
    else {
        if (n >= k && n % k == 0) {
            if (!hashTraverse[ch]) {
                hashTable[ch] = true;
            }
        }
        else {
            hashTraverse[ch] = true;
            hashTable[ch] = false;
        }
        n = 1;
    }
}

int main() {
#ifdef _DEBUG
    freopen("data.txt", "r+", stdin);
#endif // _DEBUG

    std::ios::sync_with_stdio(false);

    string str; int k, n = 1;
    cin >> k >> str;

    for (int i = 1; i < str.size(); ++i) {
        bool isSame = str[i] == str[i - 1];
        Stucked(isSame, str[i - 1], n, k);
    }
    Stucked(false, str[str.size() - 1], n, k);

    for (int i = 0; i < str.size(); ++i) {
        if (hashTable[str[i]] && !isPrint[str[i]]) {
            cout << str[i];
            isPrint[str[i]] = true;
        }
    }
    cout << endl;

    for (int i = 0; i < str.size(); ++i) {
        if (!hashTable[str[i]]) {
            cout << str[i];
            n = 0;
        }
        else if (++n >= k) {
            cout << str[i];
            n = 0;
        }
    }

    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值