1134. Vertex Cover (25)
时间限制 600 ms 内存限制 65536 kB 代码长度限制 16000 B
判题程序 Standard 作者 CHEN, Yue
A vertex cover of a graph is a set of vertices such that each edge of the graph is incident to at least one vertex of the set. Now given a graph with several vertex sets, you are supposed to tell if each of them is a vertex cover or not.
Input Specification:
Each input file contains one test case. For each case, the first line gives two positive integers N and M (both no more than 104), being the total numbers of vertices and the edges, respectively. Then M lines follow, each describes an edge by giving the indices (from 0 to N-1) of the two ends of the edge.
After the graph, a positive integer K (<= 100) is given, which is the number of queries. Then K lines of queries follow, each in the format:
Nv v[1] v[2] … v[Nv]
where Nv is the number of vertices in the set, and v[i]’s are the indices of the vertices.
Output Specification:
For each query, print in a line “Yes” if the set is a vertex cover, or “No” if not.
Sample Input:
10 11
8 7
6 8
4 5
8 4
8 1
1 2
1 4
9 8
9 1
1 0
2 4
5
4 0 3 8 4
6 6 1 7 5 4 9
3 1 8 4
2 2 8
7 9 8 7 6 5 4 2
Sample Output:
No
Yes
Yes
No
No
#define _CRT_SECURE_NO_WARNINGS
#include <algorithm>
#include <iostream>
#include <vector>
#include <cstring>
#include <set>
using namespace std;
const int MaxN = 10010;
vector<int>edge[MaxN];
int N, M;
int main() {
#ifdef _DEBUG
freopen("data.txt", "r+", stdin);
#endif // _DEBUG
std::ios::sync_with_stdio(false);
cin >> N >> M;
for (int i = 0; i < M; ++i) {
int u, v;
cin >> u >> v;
edge[u].push_back(i);
edge[v].push_back(i);
}
int Q;
cin >> Q;
while (Q--) {
int vn; cin >> vn;
bool hashTable[MaxN]; memset(hashTable, 0, N + 1);
for (int i = 0; i < vn; ++i) {
int u; cin >> u;
for (int k = 0; k < edge[u].size(); ++k) hashTable[edge[u][k]] = true;
}
bool flag = true;
for (int i = 0; i < M; ++i) {
if (hashTable[i] == false) {
flag = false;
break;
}
}
flag ? (cout << "Yes\n") : (cout << "No\n");
}
return 0;
}