poj 2524 Ubiquitous Religions

题目链接:http://poj.org/problem?id=2524

题目描述:

   There are so many different religions in the world today that it is difficult to keep track of them all. You are interested in finding out how many different religions students in your university believe in.
   You know that there are n students in your university (0 < n <= 50000). It is infeasible for you to ask every student their religious beliefs. Furthermore, many students are not comfortable expressing their beliefs. One way to avoid these problems is to ask m (0 <= m <= n(n-1)/2) pairs of students and ask them whether they believe in the same religion (e.g. they may know if they both attend the same church). From this data, you may not know what each person believes in, but you can get an idea of the upper bound of how many different religions can be possibly represented on campus. You may assume that each student subscribes to at most one religion.

Input

The input consists of a number of cases. Each case starts with a line specifying the integers n and m. The next m lines each consists of two integers i and j, specifying that students i and j believe in the same religion. The students are numbered 1 to n. The end of input is specified by a line in which n = m = 0.

Output

For each test case, print on a single line the case number (starting with 1) followed by the maximum number of different religions that the students in the university believe in.

Sample Input

10 9

1 2

1 3

1 4

1 5

1 6

1 7

1 8

1 9

1 10

10 4

2 3

4 5

4 8

5 8

0 0

Sample Output

Case 1: 1

Case 2: 7

题目分析:成对的输入学生编号,每一对数字代表他们的宗教信仰是相同的,若在两组数据中有相同的数字编号则代表他们的宗教信仰是相同的,合并为1个宗教。这里就简单运用了并查集并未夹杂其他知识点。

代码:

#include<cstdio>
#include<iostream>
#include<cstdio>
using namespace std;
const int maxn=0x3f3f3f;
int a[50010];

int find(int x)
{
   return a[x]==x?x:(a[x]=find(a[x]));
}


int main()
{
    int n,m,I,J;
    int cnt=1;
    while(scanf("%d%d",&n,&m)&&n&&m)
    {
        int sum=n;//这里让宗教总数等于最大编号数,下方再根据条件自减
        for(int i=1;i<=n;i++)
            a[i]=i;
        for(int i=0;i<m;i++)
        {
          scanf("%d%d",&I,&J);
          I=find(a[I]);   //分别找各自对应的宗教
          J=find(a[J]);
          if(I!=J)      //每一对数首先保证这一对数不相同。由于不相同,故将他们的宗教合并,独立宗教少一个
          {
                a[I]=J;//路径压缩(即对应宗教相同的两个数,使两者对应的父节点相同)
                sum--;
          }

        }

       printf("Case %d: %d\n",cnt++,sum);
    }
    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值