题目链接:https://cn.vjudge.net/contest/260456#problem
题目大意:
You will be given a string which only contains ‘1’; You can merge two adjacent ‘1’ to be ‘2’, or leave the ‘1’ there. Surly, you may get many different results. For example, given 1111 , you can get 1111, 121, 112,211,22. Now, your work is to find the total number of result you can get.
Input
The first line is a number n refers to the number of test cases. Then n lines follows, each line has a string made up of ‘1’ . The maximum length of the sequence is 200.
Output
The output contain n lines, each line output the number of result you can get .
Sample Input
3 1 11 11111
Sample Output
1 2 8
分析:
输入一串数据,每组数据都由1组成。若每两个相邻的1都可以组成2,问一串数据最终会有几种组成形式(全是1的本身也是一种)。 这里有几种就涉及到了,推导找规律,最终会发现它的规律就是斐波那契,第三个是前两者的和。
另外,当1的个数较多时,就会出现数据溢出的现象,所以这里使用大数存储。
代码:
#include<cstdio>
#include<cstring>
#include<iostream>
#include<algorithm>
int c[1010][1010];//因为是大数,一维数组并不能储存数字,所以用二维,后面用来分别储存大数的每个位数
int main()
{
int T;
int r,s,i;
r=0;
memset(c,0,sizeof(c));
c[1][1]=1;//长度为1时
c[2][1]=2;//长度为2时
for(int i=1;i<=997;i++)//大数的加法
{
for(int j=1;j<=1010;j++)
{
s=c[i][j]+c[i+1][j]+r;//从第2个数开始数组中的值已经是0,只有r了,若r不为0,则s不为0,否则s也是0
c[i+2][j]=s%10;//比较高的位
r=s/10;//去掉前方高位对应的数
}
}
scanf("%d",&T);
while(T--)
{
char a[201];
scanf("%s",a);
int len=strlen(a);
if(len==1) printf("1\n");
else if(len==2) printf("2\n");
else
{
for(i=1010;i>=1;i--)
if(c[len][i])break; //当a[n][i]为0时跳出,此时的i即答案有几位数,进入下一步的输出
//从第一个不为0的数开始输出
for(;i>=1;i--)
printf("%d",c[len][i]);
printf("\n");
}
}
return 0;
}