hdu1865(斐波那契+大数)

题目链接:https://cn.vjudge.net/contest/260456#problem

题目大意:

You will be given a string which only contains ‘1’; You can merge two adjacent ‘1’ to be ‘2’, or leave the ‘1’ there. Surly, you may get many different results. For example, given 1111 , you can get 1111, 121, 112,211,22. Now, your work is to find the total number of result you can get.

Input

The first line is a number n refers to the number of test cases. Then n lines follows, each line has a string made up of ‘1’ . The maximum length of the sequence is 200.

Output

The output contain n lines, each line output the number of result you can get .

Sample Input

3
1
11
11111

Sample Output

1
2
8

分析:

输入一串数据,每组数据都由1组成。若每两个相邻的1都可以组成2,问一串数据最终会有几种组成形式(全是1的本身也是一种)。 这里有几种就涉及到了,推导找规律,最终会发现它的规律就是斐波那契,第三个是前两者的和。

另外,当1的个数较多时,就会出现数据溢出的现象,所以这里使用大数存储。

代码:

#include<cstdio>
#include<cstring>
#include<iostream>
#include<algorithm>
int c[1010][1010];//因为是大数,一维数组并不能储存数字,所以用二维,后面用来分别储存大数的每个位数
int main()
{
    int T;
    int r,s,i;
    r=0;
    memset(c,0,sizeof(c));
    c[1][1]=1;//长度为1时
    c[2][1]=2;//长度为2时
    for(int i=1;i<=997;i++)//大数的加法
    {
        for(int j=1;j<=1010;j++)
        {
            s=c[i][j]+c[i+1][j]+r;//从第2个数开始数组中的值已经是0,只有r了,若r不为0,则s不为0,否则s也是0
            c[i+2][j]=s%10;//比较高的位
            r=s/10;//去掉前方高位对应的数
        }
    }
    scanf("%d",&T);
    while(T--)
    {
        char a[201];
        scanf("%s",a);
        int len=strlen(a);
        if(len==1)  printf("1\n");
        else if(len==2)  printf("2\n");
        else
        {
            for(i=1010;i>=1;i--)
              if(c[len][i])break; //当a[n][i]为0时跳出,此时的i即答案有几位数,进入下一步的输出
                           //从第一个不为0的数开始输出
            for(;i>=1;i--)
              printf("%d",c[len][i]);
            printf("\n");
        }
    }
    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 2
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 2
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值