浙大 PAT Adavnced level 1003. Emergency

As an emergency rescue team leader of a city, you are given a special map of your country. The map shows several scattered cities connected by some roads. Amount of rescue teams in each city and the length of each road between any pair of cities are marked on the map. When there is an emergency call to you from some other city, your job is to lead your men to the place as quickly as possible, and at the mean time, call up as many hands on the way as possible.

Input

Each input file contains one test case. For each test case, the first line contains 4 positive integers: N (<= 500) - the number of cities (and the cities are numbered from 0 to N-1), M - the number of roads, C1 and C2 - the cities that you are currently in and that you must save, respectively. The next line contains N integers, where the i-th integer is the number of rescue teams in the i-th city. Then M lines follow, each describes a road with three integers c1, c2 and L, which are the pair of cities connected by a road and the length of that road, respectively. It is guaranteed that there exists at least one path from C1 to C2.

Output

For each test case, print in one line two numbers: the number of different shortest paths between C1 and C2, and the maximum amount of rescue teams you can possibly gather.
All the numbers in a line must be separated by exactly one space, and there is no extra space allowed at the end of a line.

Sample Input
5 6 0 2
1 2 1 5 3
0 1 1
0 2 2
0 3 1
1 2 1
2 4 1
3 4 1
Sample Output

2 4


Advanced level里面经常碰到的一类题目,基本思想是 最短路径算法(dijkstra)+剪枝 。使用dijkstra算法,注意记录最短路径的条数,对于计算过程中碰到的相同长度的最短路径,选取能调取最多rescue team的路径。


#include <iostream>
using namespace std;
#define INFINITE 0x7fffffff
#define MAX_CITY 500

int main()
{
	int cities,roads,src,dst;
	int teams[MAX_CITY];
	// int pathmatrix[MAX_CITY];				// pathmatrix 用于存储最短路径下标
	int shortpathtable[MAX_CITY];			// shortpathtable用于存储到各点最短路径的权值和
	int final[MAX_CITY];					// final[i] = 1, 表示求的src到i的最短路径
	int matrix[MAX_CITY][MAX_CITY];			// 用来存储路径
	int same[MAX_CITY];						// 用来记录从src到i具有的相同最短路径个数
	int sum[MAX_CITY];						// 用来记录从src到i所能着急的最大团队个数

	int i, j, k, temp, min;
	cin >> cities >> roads >> src >> dst;

	for (i = 0; i != cities; ++i)
	{
		cin >> teams[i];
	}

	for (i = 0; i != cities; ++i)
	{
		for (j = 0; j != cities; ++j)
		{
			matrix[i][j] = INFINITE;
		}
		final [i] = 0;						// 全部顶点初始化为未知路径状态
		// pathmatrix[i] = 0;					// 初始化路径数组为0
	}

	for (k = 0; k != roads; ++k)
	{
		cin >> i >> j >> temp;
		matrix[i][j] = matrix[j][i] = temp;
	}

	for (i = 0; i != cities; ++i)
	{
		if (i == src)
		{
			continue;
		}

		shortpathtable[i] = matrix[src][i];		// 将与src点有连线的顶点加上权值

		if (INFINITE == shortpathtable[i])
		{
			same[i] = 0;
			sum[i] = teams[src];
		}
		else
		{
			same[i] = 1;
			sum[i] = teams[src]+teams[i];
		}
	}

	final[src] = 1;							// src到src不需要求路径
	shortpathtable[src] = 0;				// src到src最短路径为0
	same[src] = 1;
	sum[src] = teams[src];


	/************************************************************************/
	/* Dijstra算法                                                          */
	/************************************************************************/
	for (i =1; i != cities; ++i)
	{
		min = INFINITE;
		for (j = 0; j != cities; ++j)
		{
			if (!final[j] && shortpathtable[j] < min)		// 寻找距离src最近的点
			{
				k = j;
				min = shortpathtable[j];
			}
		}

		// 不进行不必要的计算 
		if (dst == k)
		{
			break;
		}

		final[k] = 1;						// 将目前找到的最近顶点置为1

		for (j = 0; j != cities; ++j)			// 修正当前最短路径及距离
		{
			if (!final[j] && matrix[k][j] != INFINITE)
			{
				if (min+matrix[k][j] < shortpathtable[j])
				{
					shortpathtable[j] = min + matrix[k][j];
					// pathmatrix[j] = k;
					same[j] = same[k];						// 重新计数
					sum[j] = sum[k] + teams[j];
				}
				else
				{
					if (min+matrix[k][j] == shortpathtable[j])
					{
						same[j] += same[k];	
						if (sum[k]+teams[j] > sum[j])			// 记录下团队的较大数值
						{
							sum[j] = sum[k]+teams[j];
						}
					}
				}
			}
		}

	}

	cout << same[dst] << ' ' << sum[dst] << endl;
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值