浙大 PAT Advanced level 1023. Have Fun with Numbers (20)

Notice that the number 123456789 is a 9-digit number consisting exactly the numbers from 1 to 9, with no duplication. Double it we will obtain 246913578, which happens to be another 9-digit number consisting exactly the numbers from 1 to 9, only in a different permutation. Check to see the result if we double it again!

Now you are suppose to check if there are more numbers with this property. That is, double a given number with k digits, you are to tell if the resulting number consists of only a permutation of the digits in the original number.

Input Specification:

Each input file contains one test case. Each case contains one positive integer with no more than 20 digits.

Output Specification:

For each test case, first print in a line "Yes" if doubling the input number gives a number that consists of only a permutation of the digits in the original number, or "No" if not. Then in the next line, print the doubled number.

Sample Input:
1234567899
Sample Output:
Yes

2469135798

输入的数字最大可以有20位,因此需要用string类型来记录输入,并要自己完成乘法运算。

需要考虑double后的结果是否和输入位数相同,以及结果和输入的数字组成是否相同。

// 全部accept
#include <iostream>
using namespace std;

#define MAXLENGTH 23
int input[MAXLENGTH];
int output[MAXLENGTH];
int judge[10];

int main()
{
  char buffer[MAXLENGTH];
  int length = 0;
  int carry = 0;                // 乘法进位
  bool flag = true;
  

  cin.getline(buffer, MAXLENGTH);
  
  while ('\0' != buffer[length])
  {
    ++length;
  }

  for (int i = MAXLENGTH-1, j = length-1; j != -1; --i, --j)
  {
    input[i] = buffer[j] - '0';
  }

  for (int i = MAXLENGTH-1; i != -1; --i)
  {
    output[i] = (input[i]*2+carry)%10;
    carry = (input[i]*2+carry)/10;
  }
  
  for (int i = MAXLENGTH-1; i != MAXLENGTH-length-1; --i)
  {
    ++judge[input[i]];
    --judge[output[i]];
  }

  for (int i = 0; i != 10; ++i)
  {
    if (0 != judge[i])
    {
      flag = false;
      break;
    }
  }

  if (flag)
  {
    cout << "Yes" << endl;
  }
  else
  {
    cout << "No" << endl;
  }
  
  flag = false;
  for (int i = 0; i != MAXLENGTH; ++i)
  {
    if (0 != output[i])
    {
      flag = true;
    }
    if (flag)
    {
      cout << output[i];
    }
  }
  cout << endl;


  system("pause");
  return 0;
}

// 有一个case不过
#if 0
#include <iostream>
using namespace std;

#define MAXLENGTH 23
int input[MAXLENGTH];
int output[MAXLENGTH];
int judge[10];

int main()
{
	char buffer[MAXLENGTH];
	int length = 0;
	int carry = 0;								// 乘法进位
	bool flag = true;
	

	cin.getline(buffer, MAXLENGTH);
	
	while ('\0' != buffer[length])
	{
		++length;
	}

	for (int i = MAXLENGTH-1, j = length-1; j != -1; --i, --j)
	{
		input[i] = buffer[j] - '0';
	}

	for (int i = MAXLENGTH-1; i != -1; --i)
	{
		output[i] = (input[i]*2+carry)%10;
		carry = (input[i]*2+carry)/10;
	}
	
	for (int i = MAXLENGTH-1; i != -1; --i)
	{
		++judge[input[i]];
		--judge[output[i]];
	}

	for (int i = 1; i != 10; ++i)
	{
		if (0 != judge[i])
		{
			flag = false;
			break;
		}
	}

	if (flag)
	{
		cout << "Yes" << endl;
	}
	else
	{
		cout << "No" << endl;
	}
	
	flag = false;
	for (int i = 0; i != MAXLENGTH; ++i)
	{
		if (0 != output[i])
		{
			flag = true;
		}
		if (flag)
		{
			cout << output[i];
		}
	}
	cout << endl;


	system("pause");
	return 0;
}

#endif


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值