洛谷 P1825 [USACO11OPEN]玉米田迷宫Corn Maze

10 篇文章 0 订阅

洛谷 P1825 [USACO11OPEN]玉米田迷宫Corn Maze


题目

题目描述

This past fall, Farmer John took the cows to visit a corn maze. But this wasn’t just any corn maze: it featured several gravity-powered teleporter slides, which cause cows to teleport instantly from one point in the maze to another. The slides work in both directions: a cow can slide from the slide’s start to the end instantly, or from the end to the start. If a cow steps on a space that hosts either end of a slide, she must use the slide.

The outside of the corn maze is entirely corn except for a single exit.

The maze can be represented by an N x M (2 <= N <= 300; 2 <= M <= 300) grid. Each grid element contains one of these items:

Corn (corn grid elements are impassable)

Grass (easy to pass through!)

A slide endpoint (which will transport a cow to the other endpoint)

The exit
A cow can only move from one space to the next if they are adjacent and neither contains corn. Each grassy space has four potential neighbors to which a cow can travel. It takes 1 unit of time to move from a grassy space to an adjacent space; it takes 0 units of time to move from one slide endpoint to the other.

Corn-filled spaces are denoted with an octothorpe (#). Grassy spaces are denoted with a period (.). Pairs of slide endpoints are denoted with the same uppercase letter (A-Z), and no two different slides have endpoints denoted with the same letter. The exit is denoted with the equals sign (=).

Bessie got lost. She knows where she is on the grid, and marked her current grassy space with the ‘at’ symbol (@). What is the minimum time she needs to move to the exit space?

去年秋天,奶牛们去参观了一个玉米迷宫,迷宫里有一些传送装置,可以将奶牛从一点到另一点进行瞬间转移。这些装置可以双向使用:一头奶牛可以从这个装置的起点立即到此装置的终点,同时也可以从终点出发,到达这个装置的起点。如果一头奶牛处在这个装置的起点或者终点,这头奶牛就必须使用这个装置。

玉米迷宫的外部完全被玉米田包围,除了唯一的一个出口。

这个迷宫可以表示为N×M的矩阵(2 ≤ N ≤ 300; 2 ≤ M ≤ 300),矩阵中的每个元素都由以下项目中的一项组成:

 玉米,这些格子是不可以通过的。

 草地,可以简单的通过。

 一个装置的结点,可以将一头奶牛传送到相对应的另一个结点。

 出口

奶牛仅可以在相邻两个格子之间移动,要在这两个格子不是由玉米组成的前提下才可以移动。奶牛能在一格草地上可能存在的四个相邻的格子移动。从草地移动到相邻的一个格子需要花费一个单位的时间,从装置的一个结点到另一个结点需要花费0个单位时间。

被填充为玉米的格子用“#”表示,草地用“.”表示,每一对装置的结点由相同的大写字母组成“A-Z”,且没有两个不同装置的结点用同一个字母表示,出口用“=”表示。

Bessie在这个迷宫中迷路了,她知道她在矩阵中的位置,将Bessie所在的那一块草地用“@”表示。求出Bessie需要移动到出口处的最短时间。

例如以下矩阵,N=5,M=6:

###=##
#.W.##
#.####
#.@W##
######

唯一的一个装置的结点用大写字母W表示。

最优方案为:先向右走到装置的结点,花费一个单位时间,再到装置的另一个结点上,花费0个单位时间,然后再向右走一个,再向上走一个,到达出口处,总共花费了3个单位时间。

输入输出格式

输入格式:
第一行:两个用空格隔开的整数N和M;

第2-N+1行:第i+1行描述了迷宫中的第i行的情况(共有M个字符,每个字符中间没有空格。)

输出格式:
一个整数,表示Bessie到达终点所需的最短时间。

输入输出样例

输入样例#1:

5 6
###=##
#.W.##
#.####
#.@W##
######

输出样例#1:

3

题解

BFS,注意TP的判断,要在入口传送门标记使用过,而不是在出口传送门标记


代码

#include<cstdio>
#include<cstring>
#include<iostream>
using namespace std;

int n,m,head,tail,sign;
int flag[4][2]={{1,0},{-1,0},{0,1},{0,-1}};
bool vis[305][305];
char map[305][305];
struct des
{
    int x,y,z;
} q[90005];
struct go
{
    int x,y;
} tp[26][3];

bool check(int x,int y)
{
    if (x<1||y<1||x>n||y>m||map[x][y]=='#'||vis[x][y]==true) return false;
     else return true;
}

void find(int x,int y)
{
    tail++;
    vis[x][y]=true;
    if ('A'<=map[x][y]&&map[x][y]<='Z')
        if (x==tp[map[x][y]-'A'][1].x&&y==tp[map[x][y]-'A'][1].y) {
            q[tail].x=tp[map[x][y]-'A'][2].x;
            q[tail].y=tp[map[x][y]-'A'][2].y;
        }
         else {
            q[tail].x=tp[map[x][y]-'A'][1].x;
            q[tail].y=tp[map[x][y]-'A'][1].y;
        }
     else {
        q[tail].x=x;q[tail].y=y;
    }
    q[tail].z=q[head].z+1;
    if (map[x][y]=='=') {
        cout<<q[tail].z;
        sign=1;
    }
}

int main()
{
    cin>>n>>m;
    memset(tp,0,sizeof(tp));
    memset(q,0,sizeof(q));
    for (int i=1;i<=n;i++)
     for (int j=1;j<=m;j++)
     {
        cin>>map[i][j];
        if (map[i][j]=='@') {
            q[1].x=i;q[1].y=j;
         }
        if ('A'<=map[i][j]&&map[i][j]<='Z') {
            tp[map[i][j]-'A'][0].x++;
            tp[map[i][j]-'A'][tp[map[i][j]-'A'][0].x].x=i;
            tp[map[i][j]-'A'][tp[map[i][j]-'A'][0].x].y=j;
        }
     }
    int x,y;
    head=0;tail=1;sign=0;
    while (head<tail)
    {
        if (sign==1) return 0;
        head++;
        x=q[head].x;y=q[head].y;
        for (int i=0;i<4;i++)
         if (check(x+flag[i][0],y+flag[i][1])) find(x+flag[i][0],y+flag[i][1]);
    }
}
  • 1
    点赞
  • 3
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值