Leftmost Digit

Problem Description
Given a positive integer N, you should output the leftmost digit of N^N.
 

Input
The input contains several test cases. The first line of the input is a single integer T which is the number of test cases. T test cases follow.
Each test case contains a single positive integer N(1<=N<=1,000,000,000).
 

Output
For each test case, you should output the leftmost digit of N^N.
 

Sample Input
  
  
2 3 4
 

Sample Output
  
  
2 2
Hint
In the first case, 3 * 3 * 3 = 27, so the leftmost digit is 2. In the second case, 4 * 4 * 4 * 4 = 256, so the leftmost digit is 2.
 

Author
Ignatius.L
 题意:
求n^n阶乘的最左边的一位;
分析:
考虑到本题的数据太大,故不可直接计算。
选择用log函数,
有m=n^n;两边取对数,得log10(m)=nlog10(n);得m=10^(nlog10(n));
因为10的阶乘得到数首位是1;所以只许看nlog10(n)的小数部分;
10^0=1<10^x(0<x<1)<10^1=10;
所以只需判断nlog10(n);
代码:
#include<stdio.h>
#include<math.h>
int main(){
	int n,i,j,m;
	__int64 b,d;
	double a,c;
	scanf("%d",&n);
	while(n--)
	{
		scanf("%d",&m);
		a=m*log10(m);
		b=(__int64)a;
		c=a-b;
		d=(__int64)(pow(10,c));//pow函数模型pow(float a,float b)
		printf("%I64d\n",d);
	}
	return 0;
}





  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值