POJ 1679

The Unique MST
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 33830 Accepted: 12297

Description

Given a connected undirected graph, tell if its minimum spanning tree is unique.

Definition 1 (Spanning Tree): Consider a connected, undirected graph G = (V, E). A spanning tree of G is a subgraph of G, say T = (V', E'), with the following properties:
1. V' = V.
2. T is connected and acyclic.

Definition 2 (Minimum Spanning Tree): Consider an edge-weighted, connected, undirected graph G = (V, E). The minimum spanning tree T = (V, E') of G is the spanning tree that has the smallest total cost. The total cost of T means the sum of the weights on all the edges in E'.

Input

The first line contains a single integer t (1 <= t <= 20), the number of test cases. Each case represents a graph. It begins with a line containing two integers n and m (1 <= n <= 100), the number of nodes and edges. Each of the following m lines contains a triple (xi, yi, wi), indicating that xi and yi are connected by an edge with weight = wi. For any two nodes, there is at most one edge connecting them.

Output

For each input, if the MST is unique, print the total cost of it, or otherwise print the string 'Not Unique!'.

Sample Input

2
3 3
1 2 1
2 3 2
3 1 3
4 4
1 2 2
2 3 2
3 4 2
4 1 2

Sample Output

3
Not Unique!

题解:

        次小生成树模板,没什么好说的= =

#include <stdio.h>
#include <string.h>
#include <algorithm>
#include<iostream>
using namespace std;
const int maxn = 510;
const int inf = 0x3f3f3f3f;
int Map[maxn][maxn];//邻接矩阵存图
int Max[maxn][maxn];//表示最小生成树中i到j的最大边权
bool used[maxn][maxn];//判断该边是否加入最小生成树
int pre[maxn];
int dis[maxn];
void init(int n)
{
	for (int i = 1; i <= n; i++)
		for (int j = 1; j <= n; j++)
			if (i == j) Map[i][j] = 0;
			else Map[i][j] = inf;
}
void read(int m)
{
	int u, v, w;
	for (int i = 0; i < m; i++)
	{
		cin >> u >> v >> w;
		Map[u][v] = Map[v][u] = w;
	}
}
int prim(int n)
{
	int ans = 0;
	bool vis[maxn];
	memset(vis, false, sizeof(vis));
	memset(used, false, sizeof(used));
	memset(Max, 0, sizeof(Max));
	for (int i = 2; i <= n; i++)
	{
		dis[i] = Map[1][i];
		pre[i] = 1;
	}
	pre[1] = 0;
	dis[1] = 0;
	vis[1] = true;
	for (int i = 2; i <= n; i++)
	{
		int min_dis = inf, k;
		for (int j = 1; j <= n; j++)
		{
			if (!vis[j] && min_dis > dis[j])
			{
				min_dis = dis[j];
				k = j;
			}
		}
		if (min_dis == inf) return -1;//如果不存在最小生成树
		ans += min_dis;
		vis[k] = true;
		used[k][pre[k]] = used[pre[k]][k] = true;
		for (int j = 1; j <= n; j++)
		{
			if (vis[j]) Max[j][k] = Max[k][j] = max(Max[j][pre[k]], dis[k]);
			if (!vis[j] && dis[j] > Map[k][j])
			{
				dis[j] = Map[k][j];
				pre[j] = k;
			}
		}
	}
	return ans;//最小生成树的权值之和
}
int smst(int n, int min_ans)//min_ans 是最小生成树的权值和
{
	int ans = inf;
	for (int i = 1; i <= n; i++)//枚举最小生成树之外的边
		for (int j = i + 1; j <= n; j++)
			if (Map[i][j] != inf && !used[i][j])
				ans = min(ans, min_ans + Map[i][j] - Max[i][j]);
	if (ans == inf) return -1;
	return ans;
}
void solve(int n)
{
	int ans = prim(n);
	if (ans == -1)
	{
		puts("Not Unique!");
		return;
	}
	if (smst(n, ans) == ans)
		printf("Not Unique!\n");
	else
		printf("%d\n", ans);
}

int main()
{
	int T, n, m;
	cin >> T;
	while (T--)
	{
		cin >> n >> m;
		init(n);
		read(m);
		solve(n);
	}
	return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值