ZCMU 1021: Boy or Girl

文章讲述了主人公在论坛上通过观察用户名中不同字符数量来判断用户性别的方法,如果字符数奇数则认为是男性,偶数则女性。给出一个字符串作为输入,程序会根据这个规则输出建议是否与用户交流。
摘要由CSDN通过智能技术生成

Description

Those days, many boys use beautiful girls' photos as avatars in forums. So it is pretty hard to tell the gender of a user at the first glance. Last year, our hero went to a forum and had a nice chat with a beauty (he thought so). After that they talked very often and eventually they became a couple in the network.

But yesterday, he came to see "her" in the real world and found out "she" is actually a very strong man! Our hero is very sad and he is too tired to love again now. So he came up with a way to recognize users' genders by their user names.

This is his method: if the number of distinct characters in one's user name is odd, then he is a male, otherwise she is a female. You are given the string that denotes the user name, please help our hero to determine the gender of this user by his method.

Input

Every line contains a non-empty string, that contains only lowercase English letters — the user name. This string contains at most 100 letters.

Output

If it is a female by our hero's method, print "CHAT WITH HER!" (without the quotes), otherwise, print "IGNORE HIM!" (without the quotes).

Sample Input

wjmzbmr xiaodao sevenkplus

Sample Output

CHAT WITH HER! IGNORE HIM! CHAT WITH HER!

#include<stdio.h>
#include<string.h>
int main()
{
	char a[100];
	while(~scanf("%s",&a)){
		int i,j,s=0;
		for(i=0;i<strlen(a);i++){
			for(j=i+1;j<strlen(a);j++){
				if(a[i]==a[j])s++;
			}
		}
		if((strlen(a)-s)%2==0)printf("CHAT WITH HER!\n");
		else printf("IGNORE HIM!\n");
	}
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值