杭电——Max Sum

Problem Description
Given a sequence a[1],a[2],a[3]......a[n], your job is to calculate the max sum of a sub-sequence. For example, given (6,-1,5,4,-7), the max sum in this sequence is 6 + (-1) + 5 + 4 = 14.
 

Input
The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line starts with a number N(1<=N<=100000), then N integers followed(all the integers are between -1000 and 1000).
 

Output
For each test case, you should output two lines. The first line is "Case #:", # means the number of the test case. The second line contains three integers, the Max Sum in the sequence, the start position of the sub-sequence, the end position of the sub-sequence. If there are more than one result, output the first one. Output a blank line between two cases.
 

Sample Input
  
  
2 5 6 -1 5 4 -7 7 0 6 -1 1 -6 7 -5
 

Sample Output
  
  
Case 1: 14 1 4 Case 2: 7 1 6

我的代码竟然没有AC,检查了很多遍还是没找出bug:

#include <stdio.h>
#include <stdlib.h>

/************************************************************************/
/* 没有AC,?????????                                           */
/************************************************************************/
void CountMax(int *array, int index, int N)
{
	int startIndex,endIndex;
	int maxsum = 0;
	int sum = 0;
	startIndex = 0;
	for (int i = 0; i < N; i++)
	{
		sum += array[i];
		if(sum > maxsum)
		{
			endIndex = i;
			maxsum = sum;
		}
		if(sum < 0)
		{
			sum = 0;
			startIndex = i+1;
		}
	}
	printf("Case %d:\n",index);
	printf("%d %d %d\n",maxsum,startIndex+1,endIndex+1);
}
int main()
{
	int T;//number of case
	int N;//numbers
	int i,j;
	scanf("%d",&T);
	for (i = 1; i <= T; i++)
	{
		scanf("%d",&N);
		int *arraynum = (int*)malloc(N*sizeof(int));
		for (j = 0; j < N; j++)
		{
			scanf("%d",&arraynum[j]);
		}
		CountMax(arraynum,i,N);
	}

	return 0;
}

下面附上别人AC的代码,请高手指出我的错。

#include<iostream>  
using namespace std;  
#define Min -999999  
int main()  
{  
	int data[100000],start,end;  
	int m;  
	int step=1;  
	cin>>m;      
	while(m--)  
	{  
		int n;  
		cin>>n;  
		for (int i=1; i<=n;i++)  
			cin>>data[i];  
		int max = Min;  
		int k=1;  
		int sum = 0;  
		for (int i=1; i<=n; i++)  
		{  
			sum = sum + data[i];  
			if (sum > max)  
			{  
				max = sum;  
				start=k;  
				end=i;  
			}  
			if(sum<0)  
			{  
				sum=0;  
				k=i+1;  
			}  
		}  
		if(step!=1)  
			cout<<endl;  
		cout<<"Case "<<step<<":"<<endl;  
		cout<<max<<" "<<start<<" "<<end<<endl;  
		step++;  
	}  
	return 0;  
}  


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
对于计算机专业的学生而言,参加各类比赛能够带来多方面的益处,具体包括但不限于以下几点: 技能提升: 参与比赛促使学生深入学习和掌握计算机领域的专业知识与技能,如编程语言、算法设计、软件工程、网络安全等。 比赛通常涉及实际问题的解决,有助于将理论知识应用于实践中,增强问题解决能力。 实践经验: 大多数比赛都要求参赛者设计并实现解决方案,这提供了宝贵的动手操作机会,有助于积累项目经验。 实践经验对于计算机专业的学生尤为重要,因为雇主往往更青睐有实际项目背景的候选人。 团队合作: 许多比赛鼓励团队协作,这有助于培养学生的团队精神、沟通技巧和领导能力。 团队合作还能促进学生之间的知识共享和思维碰撞,有助于形成更全面的解决方案。 职业发展: 获奖经历可以显著增强简历的吸引力,为求职或继续深造提供有力支持。 某些比赛可能直接与企业合作,提供实习、工作机会或奖学金,为学生的职业生涯打开更多门路。 网络拓展: 比赛是结识同行业人才的好机会,可以帮助学生建立行业联系,这对于未来的职业发展非常重要。 奖金与荣誉: 许多比赛提供奖金或奖品,这不仅能给予学生经济上的奖励,还能增强其成就感和自信心。 荣誉证书或奖状可以证明学生的成就,对个人品牌建设有积极作用。 创新与研究: 参加比赛可以激发学生的创新思维,推动科研项目的开展,有时甚至能促成学术论文的发表。 个人成长: 在准备和参加比赛的过程中,学生将面临压力与挑战,这有助于培养良好的心理素质和抗压能力。 自我挑战和克服困难的经历对个人成长有着深远的影响。 综上所述,参加计算机领域的比赛对于学生来说是一个全面发展的平台,不仅可以提升专业技能,还能增强团队协作、沟通、解决问题的能力,并为未来的职业生涯奠定坚实的基础。
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值