C语言实验——保留字母

C语言实验——保留字母

Time Limit: 1000 ms Memory Limit: 65536 KiB

Submit Statistic

Problem Description

编一个程序,输入一个字符串,将组成字符串的所有非英文字母的字符删除后输出。

Input

一个字符串,长度不超过80个字符。

Output

删掉非英文字母后的字符串。

Sample Input

abc123+xyz.5

Sample Output

abcxyz

Hint

Source

ZJGSU


using System;
using System.Collections.Generic;
using System.Linq;
using System.Text;
using System.Threading.Tasks;

namespace test1
{
    class Program
    {
        static void Main(string[] args)
        {
            string s;
            s = Console.ReadLine();
          
            
            int i, j=0;
            for(i=0;i<s.Length;i++)
            {
                char c = s[i];
                if((c>='a'&&c<='z')||(c>='A'&&c<='Z'))
                {
                    Console.Write(c);
                }
                if(i==s.Length-1)
                {
                    Console.WriteLine();
                }
            }
            
         
        }
    }
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值