C#:大小写转换

大小写转换

Time Limit: 1000 ms Memory Limit: 65536 KiB

Submit Statistic

Problem Description

X现在要学习英文以及各种稀奇古怪的字符的了。现在他想把一串字符中的小写字母变成大写字符,大写字母变成小写字母,其他的保持不变。

Input

 输入有多组。

每组输入一个字符串,长度不大于80,不包含空格。

Output

 输出转换后的字符串

Sample Input

A*
B+

Sample Output

a*
b+

Hint

 

Source

zmx

 

using System;
using System.Collections.Generic;
using System.Linq;
using System.Text;
using System.Threading.Tasks;

namespace test1
{
    class Program
    {
        static void Main(string[] args)
        {
            string s;

            while ((s = Console.ReadLine()) != string.Empty)
            {
                char[] a = s.ToCharArray();
                int i;
                for (i = 0; i < s.Length; i++)
                {
                    if (a[i] >= 'a' && a[i] <= 'z')
                    {
                        a[i] = (char)(a[i] - 32);
                    }
                    else if (a[i] >= 'A' && a[i] <= 'Z')
                    {
                        a[i] = (char)(a[i] + 32);
                    }

                }
                Console.WriteLine(a);
            }
        }
    }
}

 

  • 0
    点赞
  • 3
    收藏
    觉得还不错? 一键收藏
  • 2
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 2
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值