求二叉树的深度


求二叉树的深度
Time Limit: 1000MS Memory limit: 65536K

题目描述

已知一颗二叉树的中序遍历序列和后序遍历序列,求二叉树的深度。

输入

输入数据有多组,输入50的字符串,第一个字符串表示二叉树的中序遍历,第二个表示二叉树的后序遍历。

输出

输出二叉树的深度。

示例输入

2
dbgeafc
dgebfca
lnixu
linux

示例输出

4
3
 
 
 
 
此题是根据中序序列和后序序列建树。
#include<stdio.h>
#include<iostream>
#include<stdlib.h>
#include<algorithm>
#include<string.h>
#include<queue>
using namespace std;
struct node
{
    char data;
    struct node *left;
    struct node *right;
};
struct node* create(char *s1,char *s2,int n)
{
    struct node *root;
    root=new node;
    if(n==0) return NULL;
    root->data=s2[n-1];
    int m=strchr(s1,s2[n-1])-s1;//函数strchr(string s,char c);表示查找字符c在字符串 s 中的位置,并返回这个位置
    //求左子树的结点的个数
    root->left=create(s1,s2,m);      //递归求得左右子树
    root->right=create(s1+m+1,s2+m,n-m-1);
    return root;
}
int high(struct node *root)		//注意这个求深度的函数,递归求得。
{
    if(!root)
	return 0;
	else if(!root->left&&!root->right)
		return 1;
		else return max(high(root->left),high(root->right))+1;
}
int main()
{
    char s1[1000],s2[1000];
    int n;
    struct node*root;
    root=new node;
    cin>>n;
    while(n--)
    {
        cin>>s1;
        cin>>s2;
        int m=strlen(s1);
        root=create(s1,s2,m);
        cout<<high(root)<<endl;
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值