(hdu 6129)Just do it(数位异或/规律)

链接: http://acm.hdu.edu.cn/showproblem.php?pid=6129

Time Limit: 5000/2500 MS (Java/Others) Memory Limit: 524288/524288 K (Java/Others)
Total Submission(s): 938 Accepted Submission(s): 542

Problem Description
There is a nonnegative integer sequence a1…n of length n. HazelFan wants to do a type of transformation called prefix-XOR, which means a1…n changes into b1…n, where bi equals to the XOR value of a1,…,ai. He will repeat it for m times, please tell him the final sequence.

Input
The first line contains a positive integer T(1≤T≤5), denoting the number of test cases.
For each test case:
The first line contains two positive integers n,m(1≤n≤2×105,1≤m≤109).
The second line contains n nonnegative integers a1…n(0≤ai≤230−1).

Output
For each test case:
A single line contains n nonnegative integers, denoting the final sequence.

Sample Input
2
1 1
1
3 3
1 2 3

Sample Output
1
1 3 1

Source
2017 Multi-University Training Contest - Team 7

题意:求输入长度为n的序列a,序列元素范围[0,2^30-1],对序列a的前缀进行异或操作,进行m次(1<=m<10^9),问m次后得到的序列是什么并输出?

分析: 先就第二个样例 依次把前几个写出来
原始序列 1 2 3
第一次: 1 3 0
第二次: 1 2 2
第三次: 1 3 1
第四次: 1 2 3

发现不管什么序列经过四次操作后会变回原来的序列,但是就这样写会TLE
那就先换一中思路吧,,

观察序列,结合异或操作的特性,
m=1时,从第一位开始全部进行一次异或操作
m=2时,从第二位开始全部进行一次异或操作
m=3时,先从第一位开始全部进行一次异或,再从第二位全部进行一次异或
发现了一个很重要的东西。 这和m的二进制最右边的第一个1有关

3 的 二进制为11, 求出二进制的最右边的第一个1代表的十进制数 tmp=m&(-m)
每次从tmp个数以后进行异或,m-=tmp;
m==0时得到的数列即为所求

这种方法最多进行 30次,m的最大值为10^9, 时间复杂度约为O(C*n),C就是m的二进制中1的个数

#include<cstdio>
#include<cstring>
#include<algorithm>
#include<vector>
using namespace std;
#define mem(a,n) memset(a,n,sizeof(a))
typedef long long LL;
const int N=2e5+5;
const int INF=0x3f3f3f3f;
LL a[N];
int main()
{
    int t;
    scanf("%d",&t);
    while(t--)
    {
        int n,m;
        scanf("%d%d",&n,&m);
        for(int i=0; i<n; i++)
            scanf("%lld",&a[i]);
//       printf("n=%d m=%d\n",n,m);
        while(m)
        {
            int tmp=m&(-m);
            for(int i=tmp;i<n;i++)
                a[i]^=a[i-tmp];
            m-=tmp;
        }
        for(int i=0; i<n-1; i++)
            printf("%lld ",a[i]);
        printf("%lld\n",a[n-1]);
    }
    return 0;
}

下面来自于:http://www.cnblogs.com/Suwako1997/p/7373981.html
是利用4次会还原规律写的,貌似差不多。。

#include<cstdio>
#include<cstring>
#include<algorithm>
#include<vector>
using namespace std;
#define mem(a,n) memset(a,n,sizeof(a))
typedef long long LL;
const int N=2e5+5;
const int INF=0x3f3f3f3f;
LL a[N];
int main()
{
    int t;
    scanf("%d",&t);
    while(t--)
    {
        int n,m;
        scanf("%d%d",&n,&m);
        for(int i=0; i<n; i++)
            scanf("%lld",&a[i]);
//       printf("n=%d m=%d\n",n,m);
        LL tmp=1;
        while(tmp*4<=m)
            tmp*=4;
        while(m)
        {
            while(m>=tmp)
            {
                for(int i=tmp; i<n; i++)
                    a[i]^=a[i-tmp];
                m-=tmp;
            }
            tmp/=4;
        }
        for(int i=0; i<n-1; i++)
            printf("%lld ",a[i]);
        printf("%lld\n",a[n-1]);
    }
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值