【PAT甲级】1147 Heaps(30 分)(堆)

25 篇文章 0 订阅

题目链接

In computer science, a heap is a specialized tree-based data structure that satisfies the heap property: if P is a parent node of C, then the key (the value) of P is either greater than or equal to (in a max heap) or less than or equal to (in a min heap) the key of C. A common implementation of a heap is the binary heap, in which the tree is a complete binary tree. (Quoted from Wikipedia at https://en.wikipedia.org/wiki/Heap_(data_structure))

Your job is to tell if a given complete binary tree is a heap.

Input Specification:

Each input file contains one test case. For each case, the first line gives two positive integers: M (≤ 100), the number of trees to be tested; and N (1 < N ≤ 1,000), the number of keys in each tree, respectively. Then M lines follow, each contains N distinct integer keys (all in the range of int), which gives the level order traversal sequence of a complete binary tree.

Output Specification:

For each given tree, print in a line Max Heap if it is a max heap, or Min Heap for a min heap, or Not Heap if it is not a heap at all. Then in the next line print the tree's postorder traversal sequence. All the numbers are separated by a space, and there must no extra space at the beginning or the end of the line.

Sample Input:

3 8
98 72 86 60 65 12 23 50
8 38 25 58 52 82 70 60
10 28 15 12 34 9 8 56

Sample Output:

Max Heap
50 60 65 72 12 23 86 98
Min Heap
60 58 52 38 82 70 25 8
Not Heap
56 12 34 28 9 8 15 10

题意:给定一个二叉树的层序序列,问是否是一个堆,大顶堆还是小顶堆,或者不是堆,并输出后序序列。

思路:通过层序序列的前两个元素,t[0],t[1],若t[0]大,则可能是大顶堆,反之可能是小顶堆;然后判断根节点的所有孩子节点是否满足堆的性质。数据结构-堆(heap) 后序序列,根据下标和二叉树的性质递归输出

代码:

#include <map>
#include <set>
#include <queue>
#include <stack>
#include <cmath>
#include <cstdio>
#include <string>
#include <vector>
#include <climits>
#include <sstream>
#include <cstring>
#include <iostream>
#include <algorithm>
using namespace std;
#define rep(i,a,n) for(int i=a;i<n;i++)
#define mem(a,n) memset(a,n,sizeof(a))
#define lowbit(i) ((i)&(-i))
typedef long long ll;
typedef unsigned long long ull;
const ll INF=0x3f3f3f3f;
const double eps = 1e-6;
const int N = 1e5+5;

int T,n;
vector<int>t;
void postOrder(int id) {
    if(id>=n) return ;
    postOrder(id*2+1);
    postOrder(id*2+2);
    printf("%d%s",t[id],id==0?"\n":" ");
}
int main() {
    scanf("%d%d",&T,&n);
    t.resize(n);
    while(T--) {
        for(int j=0; j<n; j++) {
            scanf("%d",&t[j]);
        }
        int flag=t[0]>t[1]?1:-1;/// flag=1表示大顶堆,-1表示小顶堆
        for(int j=0; j<=(n-1)/2; j++) {
            int left=j*2+1,right=j*2+2;
            if((flag==1&&(t[j]<t[left] || (right < n && t[j] < t[right])) || (flag==-1 && (t[j]>t[left] || right<n&&t[j]>t[right])))) {
                /// 孩子节点不符合大顶堆或小顶堆的性质
                flag=0;
            }
        }
        if(flag==0) {
            printf("Not Heap\n");
        } else {
            printf("%s Heap\n",flag==1?"Max":"Min");
        }
        postOrder(0);
    }
    return 0;
}

参考博客:

柳婼 の blog

 

 

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值