HDU 2196

Computer
Time Limit:1000MS Memory Limit:32768KB 64bit IO Format:%I64d & %I64u
Submit
这里写图片描述
Status
Description
A school bought the first computer some time ago(so this computer’s id is 1). During the recent years the school bought N-1 new computers. Each new computer was connected to one of settled earlier. Managers of school are anxious about slow functioning of the net and want to know the maximum distance Si for which i-th computer needs to send signal (i.e. length of cable to the most distant computer). You need to provide this information.

Hint: the example input is corresponding to this graph. And from the graph, you can see that the computer 4 is farthest one from 1, so S1 = 3. Computer 4 and 5 are the farthest ones from 2, so S2 = 2. Computer 5 is the farthest one from 3, so S3 = 3. we also get S4 = 4, S5 = 4.
Input
Input file contains multiple test cases.In each case there is natural number N (N<=10000) in the first line, followed by (N-1) lines with descriptions of computers. i-th line contains two natural numbers - number of computer, to which i-th computer is connected and length of cable used for connection. Total length of cable does not exceed 10^9. Numbers in lines of input are separated by a space.
Output
For each case output N lines. i-th line must contain number Si for i-th computer (1<=i<=N).
Sample Input
5
1 1
2 1
3 1
1 1
Sample Output
3
2
3
4
4

题意:给你n个电脑,第 i 行(注意 i 就是第几行)就是第 i 台电脑,下面再给你与第 i 台电脑相连的电脑 x 与距离 d,问你每个电脑的最大联通范围
题解:还是树的直径问题,不过是多弄了一个数组记录最大距离

#include <stdio.h>
#include <cstring>
#include <queue>
using namespace std;
#define M 100010

struct node
{
    int from, to, val, next;
};
node edge[M * 2];
int head[M], edgenum;
void getmap(int u, int v, int val)
{
    node e = {u, v, val, head[u]};
    edge[edgenum] = e;
    head[u] = edgenum++;
}
void init()
{
    memset(head, -1, sizeof(head));
    edgenum = 0;
}
int dist[M], ans, s, maxd[M];
bool vis[M];

void bfs(int a)
{
    memset(dist, 0, sizeof(dist));
    memset(vis, false, sizeof(vis));
    ans = 0, vis[a] = true;
    queue<int> q;
    q.push(a);
    node e;
    while(!q.empty())
    {
        a = q.front();
        q.pop();
        for(int i=head[a]; i != -1; i=edge[i].next)
        {
            e = edge[i];
            if(!vis[e.to] && dist[e.to] < dist[a] + e.val)//注意是vis[e.to]不是vis[a] 
            {
                vis[e.to] = true;
                dist[e.to] = dist[a] + e.val;
                if(ans < dist[e.to])
                {
                    ans = dist[e.to];
                    s = e.to;
                }
                q.push(e.to);
            }
        }
    }
}
int main()
{
    int a, b, c, n, start, end;
    while(scanf("%d", &n) != EOF)
    {
        init();
        memset(maxd, 0, sizeof(maxd));//记录每台电脑最长的
        for(int i=2; i<=n; i++)
        {
            scanf("%d%d", &b, &c);
            getmap(i, b, c);
            getmap(b, i, c);
        }
        bfs(1);
        start = s;
        bfs(start);//找到最长的后遍历一次
        for(int i=1; i<=n; i++)
        {
            maxd[i] = dist[i];
        }
        end = s;
        bfs(end);//遍历到尾了再来一次
        for(int i=1; i<=n; i++)
        {
            if(maxd[i] < dist[i])
            {
                maxd[i] = dist[i];
            }
            printf("%d\n", maxd[i]);
        }
    }

    return 0;
}
  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值