poj1703 Find them, Catch them(带权并查集)

Find them, Catch them
Time Limit:1000MS Memory Limit:10000KB 64bit IO Format:%lld & %llu
Submit

Status

Practice

POJ 1703
Description
The police office in Tadu City decides to say ends to the chaos, as launch actions to root up the TWO gangs in the city, Gang Dragon and Gang Snake. However, the police first needs to identify which gang a criminal belongs to. The present question is, given two criminals; do they belong to a same clan? You must give your judgment based on incomplete information. (Since the gangsters are always acting secretly.)

Assume N (N <= 10^5) criminals are currently in Tadu City, numbered from 1 to N. And of course, at least one of them belongs to Gang Dragon, and the same for Gang Snake. You will be given M (M <= 10^5) messages in sequence, which are in the following two kinds:

  1. D [a] [b]
    where [a] and [b] are the numbers of two criminals, and they belong to different gangs.

  2. A [a] [b]
    where [a] and [b] are the numbers of two criminals. This requires you to decide whether a and b belong to a same gang.
    Input
    The first line of the input contains a single integer T (1 <= T <= 20), the number of test cases. Then T cases follow. Each test case begins with a line with two integers N and M, followed by M lines each containing one message as described above.
    Output
    For each message “A [a] [b]” in each case, your program should give the judgment based on the information got before. The answers might be one of “In the same gang.”, “In different gangs.” and “Not sure yet.”
    Sample Input
    1
    5 5
    A 1 2
    D 1 2
    A 1 2
    D 2 4
    A 1 4
    Sample Output
    Not sure yet.
    In different gangs.
    In the same gang.
    题意:t 组测试数据,n个人,m次询问,D表示两个对立的人,A询问两个人的关系
    题解:带权并查集,在findp函数是将一条树上的父子关系都弄成对立的,存在权值 0, 1里面,根据并查集的特性可以在每次查询的时候重新赋权值,join函数就不需要多说,带权并查集主要是在并查集里面多一个数值记录权值,具体看代码

#include <cstdio>
#include <cstring>
#define M 100010

int pre[M], rank[M];

int findp(int x)
{
    if(x == pre[x]) return pre[x];
    int fx = pre[x];
    pre[x] = findp(pre[x]);
    rank[x] = (rank[x] + rank[fx]) & 1;//保证了子与父的rank不同 

    return pre[x];
}
void join(int x, int y)
{
    int fx = findp(x);
    int fy = findp(y);
    if(fx != fy)
    {
        pre[fy] = fx;
        rank[fy] = (rank[x] - rank[y] + 1) & 1;//让fy的rank与y相同,与x的rank不同 
    }
}
int main()
{
    int t, n, m, a, b, ans;
    scanf("%d", &t);
    while(t--)
    {
        scanf("%d%d", &n, &m);
        ans = 0;
        for(int i=0; i<=n; i++)
        {
            pre[i] = i;
            rank[i] = 0;
        }
        char al[2];
        for(int i=0; i<m; i++)
        {
            scanf("%s%d%d", al, &a, &b);
            if(al[0] == 'D')
            {
                join(a, b);
            }
            else
            {
                int fa = findp(a);
                int fb = findp(b);
                if(fa != fb)
                {
                    printf("Not sure yet.\n");
                }
                else
                {
                    if(rank[a] == rank[b])
                    {
                        printf("In the same gang.\n");
                    }
                    else
                    {
                        printf("In different gangs.\n");
                    }
                }
            }
        }
    }

    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值