HDU 4734 F(x)(数位dp)

F(x)
Time Limit: 1000/500 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 4716 Accepted Submission(s): 1757

Problem Description
For a decimal number x with n digits (AnAn-1An-2 … A2A1), we define its weight as F(x) = An * 2n-1 + An-1 * 2n-2 + … + A2 * 2 + A1 * 1. Now you are given two numbers A and B, please calculate how many numbers are there between 0 and B, inclusive, whose weight is no more than F(A).

Input
The first line has a number T (T <= 10000) , indicating the number of test cases.
For each test case, there are two numbers A and B (0 <= A,B < 109)

Output
For every case,you should output “Case #t: ” at first, without quotes. The t is the case number starting from 1. Then output the answer.

Sample Input
3
0 100
1 10
5 100

Sample Output
Case #1: 1
Case #2: 2
Case #3: 13

题意:给你 a, b;定义F(x),找到【0,b】之间有多少个数不大于 F(a);

#include <cstdio>
#include <cstring>
#define M 20
#define N 200000

int bit[M];
int dp[M][N];
int f(int a)
{
    int ans = 0, temp = 1;
    while(a)
    {
        ans += (a % 10) * temp;
        temp <<= 1;
        a /= 10;
    }
    return ans;
}

int dfs(int pos, int pre, bool limit)
{
    int ans = 0;
    if(pos < 0) return pre >= 0;
    if(pre < 0) return 0;
    if(!limit && dp[pos][pre] != -1) return dp[pos][pre];
    //对于这里的记忆化,dp里面的初始值是 0 ,然后只有下面存在符合的
    //值的时候才会变成正的,pre的存在可以保证下面的是已经算过的值
    //不需要再算 
    int up = limit ? bit[pos] : 9;
    for(int i=0; i<=up; i++)
    {
        ans += dfs(pos-1, pre-i*(1<<pos), limit && i==up);
    }
    if(!limit) dp[pos][pre] = ans;

    return ans;
}
int solve(int a, int b)
{
    int top = 0;
    while(b)
    {
        bit[top++] = b % 10;
        b /= 10;
    }
    dfs(top-1, f(a), 1);
}
int main()
{
    int t, a, b;
    scanf("%d", &t);
    memset(dp, -1, sizeof(dp));
    for(int ca=1; ca<=t; ca++)
    {
        scanf("%d%d", &a, &b);
        printf("Case #%d: %d\n", ca, solve(a, b));
    }

    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值