POJ-1276-Cash Machine

Cash Machine
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 33644 Accepted: 12180

Description

A Bank plans to install a machine for cash withdrawal. The machine is able to deliver appropriate @ bills for a requested cash amount. The machine uses exactly N distinct bill denominations, say Dk, k=1,N, and for each denomination Dk the machine has a supply of nk bills. For example,

N=3, n1=10, D1=100, n2=4, D2=50, n3=5, D3=10

means the machine has a supply of 10 bills of @100 each, 4 bills of @50 each, and 5 bills of @10 each.

Call cash the requested amount of cash the machine should deliver and write a program that computes the maximum amount of cash less than or equal to cash that can be effectively delivered according to the available bill supply of the machine.

Notes:
@ is the symbol of the currency delivered by the machine. For instance, @ may stand for dollar, euro, pound etc.

Input

The program input is from standard input. Each data set in the input stands for a particular transaction and has the format:

cash N n1 D1 n2 D2 ... nN DN

where 0 <= cash <= 100000 is the amount of cash requested, 0 <=N <= 10 is the number of bill denominations and 0 <= nk <= 1000 is the number of available bills for the Dk denomination, 1 <= Dk <= 1000, k=1,N. White spaces can occur freely between the numbers in the input. The input data are correct.

Output

For each set of data the program prints the result to the standard output on a separate line as shown in the examples below.

Sample Input

735 3  4 125  6 5  3 350
633 4  500 30  6 100  1 5  0 1
735 0
0 3  10 100  10 50  10 10

Sample Output

735
630
0
0

Hint

The first data set designates a transaction where the amount of cash requested is @735. The machine contains 3 bill denominations: 4 bills of @125, 6 bills of @5, and 3 bills of @350. The machine can deliver the exact amount of requested cash.

In the second case the bill supply of the machine does not fit the exact amount of cash requested. The maximum cash that can be delivered is @630. Notice that there can be several possibilities to combine the bills in the machine for matching the delivered cash.

In the third case the machine is empty and no cash is delivered. In the fourth case the amount of cash requested is @0 and, therefore, the machine delivers no cash.

Source



说实话这个题不太会,没多少思路,毕竟是刚学算法的渣渣。

网上看得博客说的是多重背包DP。

好在现在已经理解这个题了,对于DP还是够呛,感觉还是没有体会到精髓,仍需努力!



对于这个题,可以定义3个数组:

1 -> dp[i] 表示的是一个状态,i的是否访问过,就是说是否已经可以找给别人i块钱。

2 -> num[i]表示第i个货币的张数。

3 -> p[i]表示第i个货币的面额。



核心代码解释如下:

int Sum = 0(最大可换的钱),temp(中间变量);

for(int i = 1; i <= C; i++)

    for(int j = Sum; j >=0; j--)

        if(dp[j])//表示当前已经可以兑换j块钱;

            for(int k = 1; k <= num[i](第i种面额的最大张数); k++)

                 {

                     temp = j + k*p[i]//再兑换k张第i种货币后的钱 的总数

                      if(temp>cash)//钱给多了错误

                          continue;//之前的状态是加入第i种货币最多可以换得钱

                       dp[temp] = 1;//可以换temp块钱出现过

                       Sum = max(Sum,temp);//求最大可以换的钱数

                }



C++ 源代码

#include <iostream>
#include <cstdio>
#include <cstdlib>
#include <cstring>
#include <cmath>
#include <algorithm>
using namespace std;

int dp[100010];
int N,cash;
int num[1010],p[1010];

int main()
{
	while(~scanf("%d %d",&cash,&N))
	{
		for(int i = 1; i <= N; i++)
			scanf("%d %d", &num[i],&p[i]);

		if(!cash || !N)//如果要兑换的钱数或则银行数为0时直接输出0,并进行下一组数据的处理
		{
			printf("0\n");
			continue;
		}
		memset(dp,0,sizeof(dp));
		dp[0] = 1;

		int Sum = 0,tem;
		for(int i = 1; i <= N; i++)
			for(int j = Sum; j >= 0; j--)
				if(dp[j])
				{
					for(int k = 1; k <= num[i];k++)
					{
						tem = j+k*p[i];
						if(tem > cash)
							continue;
						dp[tem] = 1;
						Sum = max(tem,Sum);
					}
				}

		printf("%d\n",Sum);
	}
	return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值