eclipse @override 报错 解决
第一种解决方案:

@Override是JDK5就已经有了,但有个小小的Bug,就是不支持对接口的实现,认为这不是Override
JDK6修正了这个Bug,无论是对父类的方法覆盖还是对接口的实现都可以加上@Override

修改你的eclipse指定的编译器版本
在选项里的java compiler中指定版本至少在5.0以上

在myEclipse中改变编译器的方法:Project->Properties->JavaCompiler->Configure WorkspaceSetting,在弹出的页面中可以进行设置。

这个来自于:http://blog.csdn.net/CodeJoker/archive/2009/07/02/4317361.aspx

第二种解决方案:(我使用这种方法,没有问题)

在JAVA 1.5和1.6中@override的用法是有些区别的,虽然改变了JRE但eclipse还是会报错。

解决办法:Windows->Preferences-->java->Compiler-->compilercompliance level设置成1.6就OK了.

注意:

但是在导入一个工程时,编译并打包到Tomcat后,发现出现java.lang.UnsupportedClassVersionE

rror:Bad version number in .classfile异常,检查了一下我的myEclipse,我发现我的eclipse的compiler的jdk版本,tomcat所用的jdk版本不一致,后来设置成一致就可以了。看来果然是这个问题引起。

阅读更多
个人分类: 其他
想对作者说点什么? 我来说一句

没有更多推荐了,返回首页

不良信息举报

eclipse @override 报错 解决

最多只允许输入30个字

加入CSDN,享受更精准的内容推荐,与500万程序员共同成长!
关闭
关闭