hduoj1789

Doing Homework again

Time Limit: 1000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 12352    Accepted Submission(s): 7254


Problem Description
Ignatius has just come back school from the 30th ACM/ICPC. Now he has a lot of homework to do. Every teacher gives him a deadline of handing in the homework. If Ignatius hands in the homework after the deadline, the teacher will reduce his score of the final test. And now we assume that doing everyone homework always takes one day. So Ignatius wants you to help him to arrange the order of doing homework to minimize the reduced score.
 

Input
The input contains several test cases. The first line of the input is a single integer T that is the number of test cases. T test cases follow.
Each test case start with a positive integer N(1<=N<=1000) which indicate the number of homework.. Then 2 lines follow. The first line contains N integers that indicate the deadlines of the subjects, and the next line contains N integers that indicate the reduced scores.
 

Output
For each test case, you should output the smallest total reduced score, one line per test case.
 

Sample Input
  
  
3 3 3 3 3 10 5 1 3 1 3 1 6 2 3 7 1 4 6 4 2 4 3 3 2 1 7 6 5 4
 

Sample Output
  
  
0 3 5
 题解:贪心法解决。因为要扣分最少,所以应该优先解决高分的作业。将分数从高到低排序,分数相同的话deadline小的在前。用数组used维护该天到之前的天数中没有使用的。used[i]=1表示该天已占用。那么每个作业只需判断他deadline之前是否有空闲即可。
#include<stdio.h>
#include<algorithm>
#include<iostream>
#include<cstring>
using namespace std;
#define MAXN 2010 
struct Node{
 int dead,score;
}node[1020];
bool cmp(Node a,Node b)
{
 if(a.score == b.score)
 return a.dead < b.dead;
 return a.score > b.score;
}
int used[1020];

int main()
{
 int t;
 cin >> t;
 while(t--)
 {
  int ans = 0;
  int n;
  cin >> n;
  for(int i = 0;i < n;i++) cin >> node[i].dead;
  for(int i = 0;i < n;i++) cin >> node[i].score;
  sort(node,node+n,cmp);
  memset(used,0,sizeof(used));
  for(int i = 0;i < n;i++)
  {
   int flag = 0;
   for(int j = node[i].dead-1;j >= 0;j--)
   {
    if(!used[j])
    {
     used[j] = 1;
     flag = 1;
     break;
    }
    
   }
   if(!flag)
    ans += node[i].score;
  }
  cout << ans << endl;
 }
    return 0;  
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值