Maximum sum
Time Limit: 1000MS | Memory Limit: 65536K | |
Total Submissions: 45591 | Accepted: 14088 |
Description
Given a set of n integers: A={a1, a2,..., an}, we define a function d(A) as below:
Your task is to calculate d(A).
Input
The input consists of T(<=30) test cases. The number of test cases (T) is given in the first line of the input.
Each test case contains two lines. The first line is an integer n(2<=n<=50000). The second line contains n integers: a1, a2, ..., an. (|ai| <= 10000).There is an empty line after each case.
Output
Print exactly one line for each test case. The line should contain the integer d(A).
Sample Input
1 10 1 -1 2 2 3 -3 4 -4 5 -5
Sample Output
13
Hint
In the sample, we choose {2,2,3,-3,4} and {5}, then we can get the answer.
Huge input,scanf is recommended.
题意:求两个不相交的连续子序列的最大和。
思路:求连续子序列的最大和的变形问题,分别求出[s1,t1]的最大和以及[s2,t2]的最大和。
设A[i]为以i开始的最大连续子序列的和,A[i] = max(a[i], A[i-1]+a[i]),
B[i]为以i结尾的最大连续子序列的和,B[i] = max(a[i], B[i+1]+a[i])。
普通连续子序列问题,使用循环查找A中最大值作为解。而本题中需要知道不相交的最大和,即A[i-1]+B[i]中最大的值。
设置C[i]、D[i]分别为以i开始、以i结尾的当前位置出现过的最大连续子序列的和。作用相当于通过循环找到A[i]位置之前的最大值。D[i] = max(D[i-1], A[i]),C[i] = max(C[i+1], B[i])。
程序:
#include<cstring>
#include<algorithm>
#include<queue>
#include<iostream>
#include<cstdio>
#define MAXN 50010
#define INF -10000000
using namespace std;
int a[MAXN];
int A[MAXN], B[MAXN], C[MAXN], D[MAXN];
int main(){
int t;
scanf("%d", &t);
while(t--){
int n;
scanf("%d", &n);
for (int i = 1;i <= n;i++){
scanf("%d", &a[i]);
}
A[1] = a[1];
for (int i = 2;i <= n;i++){
A[i] = max(a[i], A[i-1]+a[i]);
}
D[1] = A[1];
for (int i = 2;i <= n; i++){
D[i] = max(D[i-1], A[i]);
}
B[n] = a[n];
for (int j = n-1;j >= 1;j--){
B[j] = max(a[j], B[j+1]+a[j]);
}
C[n] = B[n];
for (int i = n-1;i >= 1; i--){
C[i] = max(C[i+1], B[i]);
}
int mm = INF;
for(int i = 2;i <= n;i++){
mm = max(mm, A[i-1] + C[i]);
}
printf("%d\n", mm);
}
return 0;
}