POJ 1042

Gone Fishing

Time Limit: 2000MS Memory Limit: 32768K
Total Submissions: 39929 Accepted: 12429

Description

John is going on a fishing trip. He has h hours available (1 <= h <= 16), and there are n lakes in the area (2 <= n <= 25) all reachable along a single, one-way road. John starts at lake 1, but he can finish at any lake he wants. He can only travel from one lake to the next one, but he does not have to stop at any lake unless he wishes to. For each i = 1,...,n - 1, the number of 5-minute intervals it takes to travel from lake i to lake i + 1 is denoted ti (0 < ti <=192). For example, t3 = 4 means that it takes 20 minutes to travel from lake 3 to lake 4. To help plan his fishing trip, John has gathered some information about the lakes. For each lake i, the number of fish expected to be caught in the initial 5 minutes, denoted fi( fi >= 0 ), is known. Each 5 minutes of fishing decreases the number of fish expected to be caught in the next 5-minute interval by a constant rate of di (di >= 0). If the number of fish expected to be caught in an interval is less than or equal to di , there will be no more fish left in the lake in the next interval. To simplify the planning, John assumes that no one else will be fishing at the lakes to affect the number of fish he expects to catch. 
Write a program to help John plan his fishing trip to maximize the number of fish expected to be caught. The number of minutes spent at each lake must be a multiple of 5.

Input

You will be given a number of cases in the input. Each case starts with a line containing n. This is followed by a line containing h. Next, there is a line of n integers specifying fi (1 <= i <=n), then a line of n integers di (1 <=i <=n), and finally, a line of n - 1 integers ti (1 <=i <=n - 1). Input is terminated by a case in which n = 0.

Output

For each test case, print the number of minutes spent at each lake, separated by commas, for the plan achieving the maximum number of fish expected to be caught (you should print the entire plan on one line even if it exceeds 80 characters). This is followed by a line containing the number of fish expected. 
If multiple plans exist, choose the one that spends as long as possible at lake 1, even if no fish are expected to be caught in some intervals. If there is still a tie, choose the one that spends as long as possible at lake 2, and so on. Insert a blank line between cases.

Sample Input

2 
1 
10 1 
2 5 
2 
4 
4 
10 15 20 17 
0 3 4 3 
1 2 3 
4 
4 
10 15 50 30 
0 3 4 3 
1 2 3 
0 

Sample Output

45, 5 
Number of fish expected: 31 

240, 0, 0, 0 
Number of fish expected: 480 

115, 10, 50, 35 
Number of fish expected: 724

 

题意:给定n个池塘,总共可以钓鱼n个小时,每个池塘有个初始的渔获fi,每过五分钟fi减少di。从池塘i到i+1消耗ti分钟。

 

思路:贪心算法,每次选择可以获得最大渔获的池塘钓鱼。但是存在转移池塘占用时间的问题,不好做比较。

现做转换如下:设deadline[i]为以i池塘结束时可以钓鱼的最大时间(总时间减去从池塘1到池塘i的路程时间),这样就可以认为在池塘i钓鱼后可以不耗时地移动到其他池塘。设fish[i]为以i池塘结束时可以获得的最大渔获,则最终答案是fish[1...n]中最大的值。使用time记录每个池塘的钓鱼时间。

 

提交后报错TLE,发现while(c--)存在c可能初始为负数的可能,则成为死循环。改为while(c>0)AC。以后尽量选确定的循环条件。

程序:

#include<cstring>
#include<algorithm>
#include<queue>
#include<iostream>
#include<cstdio>
#define MAXN 100010
using namespace std;

int h, n;
int t[30], f[30], d[30]; 
int time[30][30];
int dl[30], tmp[30], fish[30];

int main(){
    while(scanf("%d", &n) && n) {
        for (int i = 1;i <= n;i++){
            for(int j = 1;j <= n;j++)
            time[i][j] = 0;
        }
        for (int i = 1;i <= n;i++) fish[i] = 0;
        scanf("%d", &h);
        int tt = h * 12;
        for (int i = 1;i <= n;i++) scanf("%d", &f[i]);
        for (int i = 1;i <= n;i++) scanf("%d", &d[i]);
        dl[1] = tt;
        for (int i = 1;i <= n-1;i++){
             scanf("%d", &t[i]);
             dl[i+1] = dl[i] - t[i];
        }
        //以i为结束点 
        for (int i = 1;i <= n;i++){
            for (int k = 1;k <= i;k++){
                tmp[k] = f[k];
            }
            int c = dl[i];
            while(c > 0){
                int m = tmp[1], index = 1;
                for (int j = 2;j <= i;j++){
                    if (tmp[j] > m){
                        m = tmp[j];
                        index = j;
                    }
                }
                fish[i] += tmp[index];
                tmp[index] -= d[index];
                if (tmp[index] < 0) tmp[index] = 0;
                time[i][index]++;
                c--;
            }
        }
        int m = -1, index = 0;
        for(int i = 1;i <= n;i++){
            if (fish[i] > m){
                m = fish[i];
                index = i;
            }
        }
        for(int i = 1;i <= n-1;i++){
            printf("%d, ", time[index][i]*5);
        }
        printf("%d\n", time[index][n]*5);
        printf("Number of fish expected: %d\n\n", m);
    }
    return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值